• 0
Sign in to follow this  
Evocati

Zybo HDMI sink

Question

Hi everybody,

    I am working on a Zybo project similar to what has been done here.

    What I wanna do is simple:

        go pro -> HDMI -> Zybo -> VGA -> monitor

    So I use dvi2rgb and rgb2vga IPs just like what Marshall did in the above post

          Marshall's schematic: https://forum.digilentinc.com/uploads/monthly_2015_05/zybo_passthrough.png.efb9f569b3fabcb8a452c95dc1ccc1e2.png

    

   So I followed the above design. But there is just no image coming on the monitor. So then I decided to only connect the dvi2rgb module and test if there is any signal coming out:

        go pro -> HDMI -> Zybo -> pixelClk to on-board LED 

   Output the pixcelClk and connected it with the on-board LED and a counter(couting 75M so the flashing LED can be recognized by my eyes.)

         My schematic: http://s19.postimg.org/ju2odjvup/hdmi_3_schematic.png

    Still the LED doesn't flash.   

 

   I am not sure if there is something wrong with the way I configure the DDC part for dvi2rgb or if the code of dvi2rgb needs to be modified before using(Jieming mentioned in the above post).

   Has anyone met similar problems? 

  

   Thank you for your time and any help or suggestions are really appreciated. 

 

Hao

    

      

 

Edited by JColvin
tags

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The problem is found and solved.

 

The resolution in the default EDID(dgl_dvi_edid.txt) only support 3 resolutions: (https://github.com/DigilentInc/vivado-library/tree/master/ip/dvi2rgb_v1_5/src)

1280x1024
1024x820
800x640

However, none of them matches the resolutions my GoPro Hero3 supports.(https://gopro.com/support/articles/hero3-faqs)

The demo project provided by digilent here(http://www.instructables.com/id/Quick-Start-Test-Demo-Zybo-Xlinx-Zynq-7000-Image-F/) has resolution 1280x720 and this is supported by GoPro.

 

Whoever have similar problem should either modify the file dgl_dvi_edid.txt, or use other video source that support more resolutions(laptop desktop with HDMI output like macbook).

Thanks,

Hao

 

 

Share this post


Link to post
Share on other sites
  • 0

Hi guys,

    I just tried this project on my board and it works. And video information read from monitor is:

        resolution 1280x720

        pixel clock 74.1MHz

   

   Since I am using the dvi2rgb core here. And in the documentation, page 7 "Default EDID", the above resolution is not supported by the default one. 

   Does it mean that I need to modify the EDID part to add the above resolution in it so that my go pro can find the right data format?

 

   Thank you very much!!

Hao

Share this post


Link to post
Share on other sites
  • 0

Hi guys,
    Here are some more details about my situation.

    My current status is:
         1) (success) Making the demo go pro project working, no coding needed. (http://www.instructables.com/id/Quick-Start-Test-Demo-Zybo-Xlinx-Zynq-7000-Image-F )
         2) (no success)Trying to reproduce Marshall's design I found in this post(https://forum.digilentinc.com/topic/560-help-with-a-zybo-video-design/#comment-1832). It's the first reply on that link.
             For short,  the design tried to do this:
                    Camera -> HDMI -> Zybo -> VGA -> monitor
                    HDMI and VGA are implemented with IPs here: https://github.com/DigilentInc/vivado-library 

 

     Some facts potentially cause this problem is this:
            1) My monitor shows the resolution is 1280x720 for the demo project. So I assume my GoPro Hero3 white edition's live feed is of this resolution.
            2) The documentation for dvi2rgb core (https://github.com/DigilentInc/vivado-library/blob/master/ip/dvi2rgb_v1_5/docs/dvi2rgb_v1_5.pdf), shows that it's default supported format does not include thie above one(Page 7 "Default EDID").
            3) To make my GoPro demo project working, the GoPro needs to be turned on after the board is turned on. This is weird and not mentioned in the demo project.
                 
     To sum up, there are just so many possible reasons. Maybe it's my GoPro's format is not supported by the default dvi2rgb setting. Maybe I made some mistake putting the dvi2rgb and rgb2vga together.
 
    Could anyone give me some directions?
 
    Thank you a lot!
Hao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this