• 0
Brooklynoutlier

Problem with UART, Arty S750 to Windows 7 SP 1

Question

Anyone else experienced a problem with communicating to an HP laptop running Windows 7 SP 1 from an Arty S7 50 through the UART port? I boiled the application down to just two simple modules, but I still get an extra character (x"FF") added to every character sent from the board to the laptop. In other words, trying to send "01234" from the board results in "0ÿ1ÿ2ÿ3ÿ4ÿ" being received (ÿ has ascii value xFF).

I've tried reinstalling drivers using files from the FTDI site, and tested with two different terminal programs (PuTTY and Termite), but the result is always the same.

Communication in the other direction works just fine.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @Brooklynoutlier,

Could you run the GPIO project Here done for Vivado 2017.2 to verify the tx for the uart. If you are using a newer version of vivado you will need to upgrade/generate the ip's by selecting tools->reports->report ip status. Then you will need to generate a wrapper. Next you can generating a bitstream.

thank you,

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now