• 0

HS3 stopped being recognized by impact after few days


Question

I'm having a problem with a brand new HS3 that has stop being recognized by impact after few days. When I received it, I used it several times to program my spartan 6 using impact. But suddently for no reason, without even having touch the board or the HS3, it stoped being recognized. So I tried the HS3 from a friend and his one is working in the same condition.

For helping diagnostic, I can say that when I connect the HS3 to windows, it is recognized by the OS. Also, I can use FT_PROG to interact with the FTDI chip, read his programmation. But I can't see the HS3 with impact or even with Adept. I also noticed that the HS3 was getting hot when it was working, but now his temperature stay low. Don't know if it could help.

So now I wonder what could be wrong, if someone has already had this problème and what I could do to fix my brand new HS3.

Thx for your help

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

HI @s.mat,

I have a couple of clarification questions to help make sure I am understanding the situation.

Your JTAG HS3 is not working, but your friends HS3 is working correctly? Are you using the same USB cable with both boards or did you try out some different USB cables?

Additionally, you are not able to see your HS3 in iMPACT or Adept (though you are on your OS)? And I presume that you can see your friends HS3 in all 3 environments (OS, Adept, iMPACT)?

Thank you,
JColvin

Link to post
Share on other sites
  • 0

I've tryed with the same USB cable and with another one. I've also tried on another board. The result is still the same. Only Windows can see the device in the device manager as a USB serial converter. I can also access it with FT_PROG but not Adept or Impact.

With an other HS3 (my friend's one), I can use it on the same computer with the same USB cable, on the same board, and I can use it with Impact or Adept.

It seem that the FTDI chip is working on my HS3 because both Windows and FT_PROG recognized it. The problem seems to be somewhere else.

s.mat

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now