• 0
Mike Placke

JTAG-HS3 programming speed variability

Question

We are using several copies of the JTAG-HS3 programming cable in our lab to load programs to a Xilinx Ultrascale+ device using Vivado via JTAG. Sometimes we can load at 15Mhz clock speed and succeed, sometimes we must cut back to 10MHz to be successful, and sometimes even 7.5MHz when dealing with the same board at different times. Since it is a big program into a big part, higher speed matters. We have tried the standard cable wiggling and swapping cables, but still have not found consistency.

Is there some issue that others have seen, updates that need to be applied, or anything else that may explain the variability?

Any feedback appreciated.

Thanks.

Mike Placke

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @Mike Placke,

I spoke with our engineer much more familiar with the JTAG HS3 and they suspected that the programming at higher speeds with that particular board has some variability and stability issues associated with it, so essentially (as per my personal understanding) you were lucky to be able to program at those higher clock rates. We do not have any Ultrascale+ devices here at Digilent, so we're not able to do some more in-depth look at the hardware.

Thanks,
JColvin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now