Recommended Posts

Hi everybody.

I am the owner of a chipkit Max32 and an ethernet shield (revision C).

When I bought them a few years ago, I managed to use the main functionalities, but then my project fall asleep and I just come back to it now :)

The problem is my PC has changed, my OS has changed (now Ubuntu 16.04.4 LTS), the mpide version has changed and I don't find a working version of the Ethernet librairies anymore.
I can start again from scratch, but all I need is a working http client example.

So my questions are :
* I installed mpide-0150-linux64-20150820. Is it OK ? (I also tried uecide with no more success)
* Which library should I use ? Ethernet ? chipKITEthernet ? DEIPck ? DNETck ?

Depending on the answer I will then precise which exact errors I get (they are different in each case...)

Thank you very much for getting me out of this trouble.

   WEC.

 

Share this post


Link to post
Share on other sites

Hi @WEC,

Welcome to the forum! MPIDE is deprecated. We have moved to using the Arduino IDE with the digilent core  There are example demo's available for ethernet use available with the digilent core. I would suggest to run them and see which one fits your needs.

cheers,

Jon

Share this post


Link to post
Share on other sites

Hi @WEC,

Update

Doing some more research  the HTTP server should be the example you use since that can go over LAN rather than WiFi. 
You will need to have the correct library commented on the deWebIOServer.cpp this will be the IM8720PHY.h rather than the MRF24G.h and the commenting out the DEWFcK.h
 

thank you,

Jon

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now