• 0
davorin

Individual windows

Question

Evenin' (o;

 

Dunno if this has been asked/requested before....but popped into my mind just few minutes ago when using the protocol analyser in debug mode where it fires the logic analyser...

As it is cumbersome to switch between those two windows it would be nice if a window could be floating to see immediate reaction.

Something similar like with EDA programs where a main windows shows a list of available programs (schematic, layout and so on), and clicking an option opens the specific function.

 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hi @davorin,

You can do that in WaveForms by clicking the windowed box on each of the individual tools page in the upper right hand corner of the GUI. Clicking the same button again will bring it back onto the main GUI. I do agree though that this isn't necessarily the "loudest" feature though. Maybe consider it like an easter egg.

Let me know if you have any questions about this.

Thanks,
JColvin

Windowed option.png

Share this post


Link to post
Share on other sites
  • 0

Ah great :-)

 

Love the software more and more...and the discovery of course....hope my company gets me an analog discovery as well to play with (o;

Only what is missing now is the combined scope/logic windows like others have (o;

 

I should have read the famous book about the Spanish guy called "Manual" ;-)

 

Share this post


Link to post
Share on other sites
  • 0

Hi @davorin,

You may be in luck, I think that feature is already there, though I don't think you have the two time bases be different without having the tool separate tools open. Manual's book is available here as well as one built into WaveForms under Help>Browse.

Thanks,
JColvin

 

 

scope and logic.png

Share this post


Link to post
Share on other sites
  • 0

Is this also in version 3.7.5?

Seems macOS versions is some steps behind...and there seems to be no beta like for Windows...

 

Anyway...was too early with my previous comment...

 

Using protocol for UART with debug mode causes the MacBook Pro running 10.12.6 to crash totally...

Only need to enter "^" + space into the TX line...

 

Attached panic report from crash...

 

 

protocol_panic.txt

Share this post


Link to post
Share on other sites
  • 0

Hi @davorin,

I think you might have this crossed with your other thread (link); unfortunately I don't know the answer for why it might have crashed.

As for the adding the Digital view to Scope, my understanding is that is should be in the Mac version. I'm on 3.7.5 on Windows 10, but that feature should have been in WaveForms for at least year, likely more.

Thanks,
JColviln

Share this post


Link to post
Share on other sites
  • 0

Yeah I mixed it a little...as it just happened in this protocol/analyzer scenario where I just wanted to send the "^" character...

But it would be awesome if this side by side analog/digital capture in the same windows is possible...

As mentioned before..need to convince my company to get me an analog discovery after two digital discoveries (o;

 

Just as a side note....great support and helping this forum here....this makes a very good product even better ;-)

 

 

Share this post


Link to post
Share on other sites
  • 0

HI @davorin,

I'll have to ping @attila for the digital view for the Scope on a Mac, though you might not get a response till tomorrow due to timezone differences. As for the sending a ^ character, you should be able to do that or send it from a file. If you're looking for escape characters, that is possible as well, with some more information in this thread.

Edit: or you might get a response sooner.

Thanks,
JColvin

Edited by JColvin

Share this post


Link to post
Share on other sites
  • 0

Well..I would just expect that it shouldn't crash an application whatever character you type with your keyboard....and furthermore to crashes the whole systems and does a reset (o;

Nevertheless I am still very happy with this product...anyway hard to find something to be useful on a mac system...that's why I just registered macintosh.tv to list all usable electronics hardware and software for macOS ;-)

Though I believe it will be a very expensive hobby to list all hardware types compatible with mac (o;

 

Share this post


Link to post
Share on other sites
  • 0

Hi @davorin

I tried to reproduce the issue under Mac but sending "^", "^ " in protocol/analyzer with different options is working fine for me. I suspect the crash is related to the usb driver discussed on the other thread.

The Protocol debug opens and configures Logic Analyzer, but the same setup can be done in Scope by adding digital lines.
Open Scope/ Add Channel/ Digital/ UART and configure to correspond to the Protocol interface, rate, polarity...

image.thumb.png.9e893fa13b2d664966361c67cc3bbe7e.png

Share this post


Link to post
Share on other sites
  • 0

Well will test on my Mac when I am at home....also under Parallels....

Anyway...my company just ordered my an analog discovery 2 @ digikey which should arrive onFriday to play with :-)

And showed the digital discovery to some fellow developers in the company today...

Looks like they all throw away their Sale devices (o;

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now