Question

Dear Community.

I've recently bought a Zybo Zynq board and i'm having some getting started problems.
Im known with both C and VHDL programming before but i've never had such a multi-purpose FGPA, dualcore board before.

I tried following some basic tutorials, like:
https://reference.digilentinc.com/zybo:gsg
http://www.zynqbook.com/
and several youtube led blinks.

But I'm experiencing different problems with all of them.
My board isnt listed in the Vivado 2015 > new project > boards list
I can't find the right settings to get the leds to the GPIO
Or when I find a "pre made tutorial led blink" its made on a earlier version of vivado and i can only open it read only, or it edits the files causing errors.

I did however get the Xililinux running at the moment ( but thats just copying bootfiles to a sd card)
Is there anyone who has a tutorial which is compatible with Vivado2015 and can get me started trying to do some actual programming in this new and unknown environment to me.

Any help would be greatly appreciated.
And sorry to ask such a question

 

Greetings

Edited by KaitlynFranz

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi there,

I think we might be able to help you with some of this. We have an excellent reference page that has a lot of information for our different boards and parts. Here is the link to the Zybo page. Also here is  a link to the "Getting Started with Zybo" page which will show you how to add the Zybo to the board listing and how to start a demo using Vivado. The reference pages contain a lot of information that should help you find the answers you're looking for. Our forums get a lot of questions about FPGAs such as the Zybo. A good majority of them have been answered also. Poke around the FPGA section to see if anyone else has similar problems and if they do there's a good chance they have been answered. But feel free to ask any and all questions you have. We are happy to try and help you the best we can.

Best Regards,

Bobby

Share this post


Link to post
Share on other sites
  • 0

Well first off I feel so stupid that I didn't look at that tutorial better, ive read it several times but the how to add the board section didnt quite get through i guess.
The tutorial seemed to be going perfect until the very end.

all my screens exactly match the tutorial
But when im writing the .elf file to the hardware i get this error message at 36%

 

 

    MMU section translation fault

    at com.xilinx.sdk.targetmanager.internal.TM.run_ps7_init(TM.java:1073)
    at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.runTargetSetup(XilinxAppLaunchConfigurationDelegate.java:486)
    at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.runApplication(XilinxAppLaunchConfigurationDelegate.java:588)
    at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.launch(XilinxAppLaunchConfigurationDelegate.java:296)
23:14:59 ERROR    : Unexpected error while launching program.
java.lang.RuntimeException: Error while running ps7_init method.
Cannot Read from target

note this only happens if I launch it on hardware (GDB)

if I run it on hardware (system debugger) The code does seem to work at least the LEDS and buttons

 

 

Share this post


Link to post
Share on other sites
  • 0

It sounds like there are a couple of issues that you are fighting right now.  First of all did you go through this tutorial?

This help you get the board files working in the Vivado.  When you get it correctly, it will show up in this window.

board_selection.thumb.png.5226a7bf8123d8

 

 

As for the errors, I frequently check that I reset the entire processor before I program it.  SDK will do it for you if you goto run->run configurations...

Try these settings:

reset_entire_system.thumb.png.758bab2038

Let me know how it goes and best of luck!

Marshall

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now