• 0
Sign in to follow this  
shingo

drivers needed for BASYS3

Question

Are there any special drivers one needs to download/install to get the BASYS3 board recognized by Windows7 64 bit?

The board powers up and can run the shipping demos but my Windows 7 machine doesn't find the board anywhere in device manager

and Vivado 14.4 cannot connect to the board. I can go so far as generating the bitstream but when I try to AutoConnect to target

it gives this warning (which seems like it should be an error). I have checked all of the usual suspects that I could think of: multiple USB ports, reboot Windoze, open and close Vivado, 

verify jumpers are set correctly, using a known good microUSB cable, but still Vivado does not find my BASYS3.

WARNING: [Labtoolstcl 44-26] No hardware targets exist on the server [localhost]
Check to make sure the cable targets connected to this machine are properly connected
and powered up, then use the disconnect_hw_server and connect_hw_server commands
to re-register the hardware targets.
 
Thank you.
 
Edited by sudharsan.sukumar
tags

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 2

Hi shingo,

It is possible that when you installed Vivado the cable drivers didn't install correctly. There is a thread in the Xilinx forum that discusses reinstalling cable drivers. If this is your issue, then reinstalling the drivers should work.

Also, I know you said you are using a known good microUSB cable. I just wanted to make sure it was know good for programming and not just for charging. 

Let me know if either of these fixes work or if you have more problems. 

Kaitlyn 

Share this post


Link to post
Share on other sites
  • 0

Hi Kaitlyn,

Thank you for the pointer. Per your recommendation I went back to the Vivado install and made sure cable drivers was selected. The install ran into an issue where it reported:

There is currently 1 open application using WinDriver. Please close all applications and press Retry.

Unfortunately, I don't know what WinDriver is nor which application would be using it. 

In any case, I closed every application down and did the install again and it completed successfully without this warning message. i then rebooted.

Unfortunately, even after the updated install for the cable drivers, I'm still getting the same warning in Vivado that no hardware targets exist.

This is consistent with Device Manager that doesn't show any Digilent devices. I also don't get the familiar bell sound when I plug and unplug the USB cable to my BASYS3 board. 

Is there a check I can do somewhere on the machine in a particular directory to see if the driver file itself is there?

Thank you.

 

Share this post


Link to post
Share on other sites
  • 0

Hi Kaitlyn,

It turned out to be just as you suspected,, a case of a shady USB cable I found one of a higher quality, i.e. thicker, more strain relief, etc and with it, the BASYS3 board was immediately recognized by Windows and Vivado. Thank you again for the help.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this