• 0
Mike

JTAG USB Cable speed

Question

Hello,

I am new to the Digilent JTAG-USB cable. I tried to use the Adept SDK samples to control my JTAG device.

I can open and enable the device. The issue is that DjtgGetPortProperties returns a bit 0 for dprpJtgSetSpeed stating that setting the speed is not supported. Indeed, when I call DjtgSetSpeed it returns FALSE.

Is setting the TCLK speed supported on the device?

Thank you,
Mike

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Unlike the other programming cables the JTAG-USB does not have speed setting option.

The serialization rates of this cable are:
DjtgPutTdiBits without TDO ~1.49 Mbps
- DjtgPutTdiBits with receive TDO ~
1.08 Mbps
DjtgGetTdoBits ~1.42 Mbps
If you need slower rates you can serialize bit by bit, using 
DjtgSetTmsTdiTck/DjtgGetTmsTdiTdoTck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now