• 0

One-Byte Only I²C Slave on chipKIT Boards

Go to solution Solved by TommyK,


On the chipKIT Uno32, uC32, DP32 and WF32, the interrupt is raised for every byte in I²C slave mode. The corresponding MCUs are the PIC32MX320F128, PIC32MX340F512H, PIC32MX250F128B and PIC32MX695F512L. I don't know for other boards / MCUs as I've only tested with those I own.

This bug/feature was confirmed at chipKIT forum and there's a related issue at the GitHub repository

Unfortunately, the question hasn't received any official answer yet. The suggested work-around isn't reliable as it requires to be set for every I²C master.

Is it a bug?

Edited by KaitlynFranz
Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
  • Solution

Hi ReiVilo,

Have you tried using Digilent's DTWI library? You can find an example in MPIDE under Wire>I2CSlaveSimEEPROM. I know the native TWI library is a bit buggy, and Keith took a long time making this library as efficient as possible.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now