• 0

Error compiling linux kernel - unrecognized --silentoldconfig option

Go to solution Solved by lijieming,


I am following the instructions in the Embedded Linux Hands-on Tutorial and got stuck at step #3 in section 4.2.  The step #2 is successful with the following output :

make ARCH=arm CROSS_COMPILE=arm-xilinx-linux-gnueabi- xilinx_zynq_defconfig
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/kconfig/conf.o
  SHIPPED scripts/kconfig/zconf.tab.c
  SHIPPED scripts/kconfig/zconf.lex.c
  SHIPPED scripts/kconfig/zconf.hash.c
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/conf
# configuration written to .config

The command in step #3 gives the following error :

make ARCH=arm CROSS_COMPILE=arm-xilinx-linux-gnueabi- scripts/kconfig/conf --silentoldconfig Kconfig
make: unrecognized option '--silentoldconfig'
Usage: make [options] [target] ...


I am using ubuntu 14.04 LTS, with Xilinx SDK version 2015.1.   Please help!



Edited by Josh
Added Tags
Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Solution

hi Hiketen,

The hands on tut has already a kind of "expired". after you

make ARCH=arm CROSS_COMPILE=arm-xilinx-linux-gnueabi- xilinx_zynq_defconfig

you can compile the kernel straightforward

make ARCH=arm CROSS_COMPILE=arm-xilinx-linux-gnueabi-

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now