• 0
Sam

PmodIA - Impedance Analyzer

Question

I am using the PmodIA - Impedance Analyzer based on AD5933 and I was trying to test it using the attached library under  MPIDE. However the code can not run well and it gives errors when run.

 

Can you please help on that?

error.png

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi, I guess that is because you miss semi-colon statements. Anyway, I have used the provided library and verify the program successfully. 

By the way, just a reminder to others, whenever you download the library, please change the folder name to remove the dash "-". Support / marketing team, can you change the folder name without dash? 

Share this post


Link to post
Share on other sites
  • 0

I check the code again and rename the folder, it gives the same error.

Can you please guide me to missing semi-colon statement?.

It state in error the error in WireIA.ccp

Share this post


Link to post
Share on other sites
  • 0

Hi Sam,

From the errors listed on your screen shot it would seem that there is an issue with semi-colon somewhere in the WireIA.cpp library. Since I'm not able to replicate your exact error, you could either try re-downloading the library to see if that fixes the error or post the WireIA.cpp and WireIA.h files in a comment (preferably in an attached file) and I'll see if I can find out what's wrong.

Thanks,
JColvin

Share this post


Link to post
Share on other sites
  • 0

Hi Sam, I moved your post into the correct forum

​Thank you. I tried to re-downloading the library, still have the same problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now