• 0
Taehyun

Use of adept utility for Arty S7 on Raspberry Pi

Question

Hello,

I want to download Xilinx bit file from Raspberry Pi to Arty S7, and adept utility for ARM seems to be the solution for it. So, I tried the following steps and it almost seems to work except the last step. I used the same bit file with Adept System on Windows, so bit file seems to be fine, and I'm suspecting if the adept utility needs some kind of update for the database.

I'm currently using digilent.adept.runtime_2.16.6-armhf.deb and digilent.adept.utilities_2.2.1-armhf.deb.

Any advice will be appreciated.

Thanks,

Taehyun

root@raspi:/home/arty# djtgcfg enum

Found 1 device(s)
Device: ArtyS7
    Product Name:   Digilent Arty S7 - 50
    User Name:      ArtyS7
    Serial Number:  210352A6C0F8


root@raspi:/home/arty# djtgcfg init -d ArtyS7

Initializing scan chain...
Found Device ID: 0362f093
Found 1 device(s):
    Device 0: XC7A ? T


root@raspi:/home/arty# djtgcfg prog -d ArtyS7 -i 0 -f main.bit

ERROR: failed to set programming file

 

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi @Taehyun,

Which raspberry PI model do you have? I also believe that this is happening because the Arty-S7 is a new board and might not have been added to the board information for adept. I am confirming this with our design engineer.

thank you,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hello Jon,

I just tried the version you attached, and now it works.

 

Just for completeness of this thread, the followings are the information of my raspberry PI:

- H/W: Raspberry Pi 3 Model B V1.2

- OS: Raspbian GNU/Linux 9 (stretch)

- Kernel: Linux 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux

 

Thank you very much for your support,

Taehyun

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now