• 0
Sign in to follow this  
LUCAS DAL PONTE FELICIANO

Chipkit Max32 bootloader

Question

Hi,

I've build a board using the pic32MX795L, the same as the Chipkit max32 for research purpose. I can upload any code using the pickit 3 and a generated code from MPLAB X, but when I upload the bootloader from Digilent site, nothing happens.

I manage to build a code in MPLAB to test the operation of the circuit and every thing seams ok, I can send and receive data over the UART1 @115200 baud with no problem. But when I upload the firmware with pickit, the device is not recognized by pic32prog. the message after a few seconds is "No target found." even when I hit the reset during upload.

There is any way that I could use the source code to Max32 to test the compilation and upload from my MPLAB that I know that's working? 

Best regards

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Hi @LUCAS DAL PONTE FELICIANO,

I took a look at this thread where another user was also having trouble getting the Max32 to use the correct oscillator frequency. You can read the last post in the thread for more details, but the feedback system with the resistors and capacitors may need to be adjusted to get the PIC32 chip to use the oscillator correctly.

Thanks,
JColvin

Share this post


Link to post
Share on other sites
  • 1

Hi @LUCAS DAL PONTE FELICIANO,

I spoke with our microcontroller engineer and they told me that for the bootloader designed for the MAX32 to potentially work on your board, your board would need to have the same UART and same frequency crystal (as opposed to oscillator) as the MAX32.

Thank you,
JColvin

Share this post


Link to post
Share on other sites
  • 0

Thank you very much Larry,

I manage to get the project upload trough MPLAB and do some checks in the code. I manage to change the Serial port for stk500v2 in order to test my circuit. 

The problem persists, I'm unable to upload a sketch from Arduino, even changing the serial port and moving my USB-Serial adapter to other port. Is there any physical configurations (pin status) or in software (pin configuration, register) to put the device in normal operation, any special trick that the bootloader requires?

I used the same schematic of the power supply of the datasheet, the only problem that I'm facing is this with Arduino. I have a Max32 here too, he works fine. 

Share this post


Link to post
Share on other sites
  • 0

JColvin, I manage to discover what was the problem and you can help me with what could cause it.

I changed the base clock, slowing the FPLLODIV from DIV_1 to DIV_2, that solved my problem but I'm now running only at 40 MHz, no problem for now, but I'll rather be capable of achieving 80 MHz instead. 

I'm using a simple 8 MHz crystal, with 22 pF on the side capacitors (i don't recall their names). Any suggestions?

Edited by LUCAS DAL PONTE FELICIANO

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this