Recommended Posts

I'm not able to update firmware from 1.4.0 to 1.296.0.

I'm running Waveforms Live Version 1.3.0 on Safari, Chrome, ... macOS 10.13.1

Am I alone ? Any idea ?

Jérôme

Share this post


Link to post
Share on other sites

Hey J3kz,

What part of the process fails?  Is the Digilent Agent running?  Are you able to add the Agent connection to WaveForms Live?  Are you able to see the COM port for the device in WaveForms Live? Are you able to start the firmware update process?

The more details you can provide the better.  Let us know and we'll help you get this figured out.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

Can you click the menu button in the upper left, and then click Settings.  Expand Advanced and the click Change Console Log and choose Console (if you refresh the page these settings will go back to their defaults).  Return to the device manager page (without refreshing the page) and try to update the firmware again.  If you open the developer console (Option-Cmd-J in Safari I think) you should see a bunch of commands printed during the update.  Wait until you get the error message about the firmware not uploading and then copy and paste the entire console log here.  We'll have a look and see if we can figure out what went wrong.

-Kristoff

Share this post


Link to post
Share on other sites

Just to confirm are you using waveformslive.com (as opposed to an offline build)?

Are you able to see the console output in Chrome?

You could also try putting the OpenScope in the bootloader before you upload the firmware.  To do this press and hold the BTNP button on the open scope while you press and release the BTNR (reset) button.  The red light should flash quickly to indicate that the device is in bootloader mode.  Try updating running the firmware update from WaveForms Live again.  I'd be interested to see the console output in both cases.

-Kristoff

(I have to run to a meeting shortly, but I'll be back later this morning.)

 

Share this post


Link to post
Share on other sites

Hey,

Are you able to get to the instrument panel and acquire data (Click Single, then Force trigger) with firmware version 1.4.0?

Were you able to put the device in bootloader mode first and then try updating the firmware?

It's possible the firmware is not being downloaded from our server correctly.  Can you try downloading the firmware manually from here.  Then go through the update firmware process but rather than choosing a version of the firmware from the drop down click Browse and select the hex file from your computer.

Let us know how it goes.

-Kristoff

 

Share this post


Link to post
Share on other sites
Quote

Are you able to get to the instrument panel and acquire data (Click Single, then Force trigger) with firmware version 1.4.0?

Yes

Quote

Were you able to put the device in bootloader mode first and then try updating the firmware?

Yes, I tried at least 2 times...

Quote

It's possible the firmware is not being downloaded from our server correctly.  Can you try downloading the firmware manually from here.  Then go through the update firmware process but rather than choosing a version of the firmware from the drop down click Browse and select the hex file from your computer.

Yes, it gaves same result too !

Share this post


Link to post
Share on other sites

Hey,

What version of the Digilent Agent do you have installed?  You can see by right clicking the Agent Icon in the system tray / dock.

Do any other firmware versions load correctly?

Are you able to try uploading firmware from another computer?

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

Hi,

I tried with Agent 0.3.6 (https://reference.digilentinc.com/learn/instrumentation/tutorials/openscope-mz/setup) and I also updated it to 1.0.1 (https://reference.digilentinc.com/reference/software/digilent-agent/start).

I just succeeded to update the firmware with OpenScope attached to a VirtualBox Win10 with latest windows Agent 1.0.1 (https://reference.digilentinc.com/reference/software/digilent-agent/start) and latest Chrome.

You're welcome,

Jérôme

Share this post


Link to post
Share on other sites

I updated the tutorial in the first link you posted.  I'm not surprised 0.3.6 didn't work, but 1.0.1 should.   I'm glad to hear that it worked from Win10, but I'm still not sure what the issue is in Mac OS.  I've never personally tried on macOS 10.13.1 (only 10.11 and 10.12) so I'll see if I can round up a macOS 10.13.1 machine and test this.

-Kristoff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now