mylim

Error Connecting to The Digilent Agent. Please Make sure The Digilent Agent Is Running.

Recommended Posts

  • Hi, i just received my OpenScope today from element14. 

Once setup and installed Waveforms Live Agent on my Windows 10 laptop and I can't add my device. 

I went through the forum and non of the recommendations worked.

Please advise.

waveformslive add_device.jpg

waveformslive connecting_device.jpg

waveformslive error_connecting.jpg

waveformslive unable to connect.jpg

Edited by mylim

Share this post


Link to post
Share on other sites
9 hours ago, Kristoff said:

Hey,

What browser are you using? Can you try using Chrome?

Can you also try navigating to the http://localhost:42135 in both your default browser and chrome and let us know what happens.

Thanks!

-Kristoff

 

Hi Kristoff, I tried both Chrome & Edge. All not working with same outcome. Any idea? I need to know if the board is OK because I got it from element14 & i have a window period to return & exchange.

Edited by mylim

Share this post


Link to post
Share on other sites

Hey,

The 3rd image you posted shows the error message you get when WaveForms Live cannot connect to the Agent.

The 4th image shows what you should see when you are able to connect to the agent.  The COM ports listed in the drop down are returned from the Agent, so this means that at least some communication is working.

  • Do you frequently see the error message in the 3rd image?
  • Can you confirm that COM 4 is the correct COM port?  You can check by opening Windows Device Manager and expanding the Ports section, then connect and disconnect the OpenScope MZ to see what COM port it shows up as.
  • Do you have administer privileges on your computer?  You could try closing the Digilent Agent (right click on the system tray icon and choose 'Exit') and the running it as Admin (Right click the Digilent Agent icon in the start menu and choose Run As Admin)

-Kristoff

 

Share this post


Link to post
Share on other sites
13 hours ago, Kristoff said:

Hey,

The 3rd image you posted shows the error message you get when WaveForms Live cannot connect to the Agent.

The 4th image shows what you should see when you are able to connect to the agent.  The COM ports listed in the drop down are returned from the Agent, so this means that at least some communication is working.

  • Do you frequently see the error message in the 3rd image? (Most of the time picture 3, Picture 4 sometimes if I uninstall digilent Agent & reinstall I may achieve this sometimes)
  • Can you confirm that COM 4 is the correct COM port?  You can check by opening Windows Device Manager and expanding the Ports section, then connect and disconnect the OpenScope MZ to see what COM port it shows up as. (the COM port is correct)
  • Do you have administer privileges on your computer?  You could try closing the Digilent Agent (right click on the system tray icon and choose 'Exit') and the running it as Admin (Right click the Digilent Agent icon in the start menu and choose Run As Admin) (Yes I have run the app as Admin)

-Kristoff

 

Hi Kristoff, I please refer to my respond in the quoted text.

Thanks,

Share this post


Link to post
Share on other sites

I managed to resolved the issue but i would strongly suggest that Digilent make a proper documentation and setup instructions to all users to avoid them from wasting days just to get it working. It is very unproductive. 

finally i found that it has to be run at COMPATIBILITY MODE. 

Anyway, thank you for helping me to solve the problem.

Edited by mylim

Share this post


Link to post
Share on other sites

Hey Mylim,

We've tested this on many Windows 10 machines and I've never had to run the application in compatibility mode before.  Which compatibility mode did you choose (Window 7, XP, etc)?

Can you provide your system information so we can try to reproduce this?

  • Click Start>>Run
  • Type dxdiag and press enter
  • Click Save All Information... in the lower left.
  • Save the text file and attach it to this thread or PM it to me.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

Hi, I have the same problem and can't get past "error connecting / make sure the agent is running" message.

  • system: win7 64 bit
  • windows firewall off
  • all antivirus that could be blocking it off
  • agent is running in the tray
  • board shows up as "USB Serial Port (COM19)"
  • tried to start up the agent as administrator and/or compatibility mode
  • tried opening from waveformslive.com or http://localhost:42135 directly (it will open, so the agent is apparently running)
  • tried Chrome and Firefox, no difference

I'm attaching dxdiag report if it helps. Also, some screenshots: https://www.dropbox.com/sh/1i8r1v2logeej10/AAD5DUfo-bpsNjnMT81Dsq8La?dl=0

You can see the XHR request to http://localhost:42135/config gets "cancelled" after 5s timeout.

Would you please advise how to resolve or further debug this.

Regards,

Mario

 

DxDiag.txt

Share this post


Link to post
Share on other sites

Hi Dharsan,

Thank you for the quick response, changing that setting did the trick! It managed to connect to the agent in about 10 seconds.

Would be worth changing that generic error message / adding hints... "could not do x" is not very helpful in general ;)

Cheers,

Mario

 

Share this post


Link to post
Share on other sites
On 8/12/2017 at 12:50 PM, sudharsan.sukumar said:

Try going to the settings page and setting the timeout to a higher value. I've attached a picture of the settings menu and you can see the http timeout setting under advanced.

-Dharsan

wflhttptimeout.PNG

Thankyou @sudharsan.sukumar  

Your recommendation is useful.

Greetings.

Share this post


Link to post
Share on other sites

MZee out of box  ... connected once , agent showed device on com 7 , for a while,  then (green gear) disappeared from the tray , reinstalled  now  agent says device on com 7 but scope will not connect..( unable to connect / communicate  to device ) . tried the time out same ... 32 bit win 7 pro + chrome , 2 hrs messing so far !  MZ  ! not a good start ..  

Edited by Logical
detail

Share this post


Link to post
Share on other sites

Hi, I had the same problem and can't get past "error connecting / make sure the agent is running" message.

On 08/12/2017 at 3:50 PM, sudharsan.sukumar said:

Try going to the settings page and setting the timeout to a higher value. I've attached a picture of the settings menu and you can see the http timeout setting under advanced.

-Dharsan

wflhttptimeout.PNG

That trick I quote worked, but it's strange because I was normally using my OS and then it stopped working and I had to do this workaround. I'm attaching dxdiag report so you have more in hands if you try to figure out what's going on. By the way, my OS does not connect to Wi-Fi anymore, I can select a network, set its password, but no connection is set...

 

Thanks

 

 

 

DxDiag.txt

Share this post


Link to post
Share on other sites

Hey jpnbino,

Can you try connecting to the OpenScope using the terminal 'menu mode' and try to connect to a wifi network there.

  1. Make sure the Digilent Agent doesn't have the COM port open (Right click the Digilent Agent and release the device).
  2. Open the COM port using a terminal application like PuTTY.  The buad rate is 1250000.
  3. Press the reset button on the OpenScope MZ
  4. A menu should be printed to the screen.
  5. Use the menu to connect to a wifi network and post the output here.
  6. Use the menu to save the network and then list the saved networks.  Post the terminal output here.

Thanks!

-Kristoff

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now