• 0

Zybo 7010 Board File Integration


Go to solution Solved by JColvin,

Question

Hello, 

I am quite new to the Zybo Zynq 7010 and Vivado in general. I have tried various tutorials involving the use of the Zynq Processing System and Axi GPIO to blink LEDs on the board. No errors in the proccess, but the LEDs do not blink at the end. I followed one thread regarding Integration of the Board files in Vivado but I still seem not to have any success as the LEDs still do not blink. I am also unable to access UART which I am guessing sterns from the same problem. 

Any solutions on installing/integrating board files/parts on Vivado for Zynq 7010 ???  

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
  • Solution

Hi @Allan,

I'm not certain if you are using the original Zybo or the Zybo Z7-10, but I would recommend following our Getting Started with Vivado IP Integrator which goes through controlling on board LEDs and switches as well as using the UART on a Zynq system. 

Let us know if you have any questions.

Thank you,
JColvin

Link to post
Share on other sites
  • 0

Thanks for the quick replies 

@JColvin I will try it out and see if that works. 

@Notarobot I tried out the "Hello World" project in the ug 1165 tutorials and USB uart failed to work. The only problem is I manually configured the Zynq Processing System like was shown in the tutorial to the best I could like the ZC702 that was used in the tutorial.

But to expand on the problem, I have tried out the tutorials in the Zynq 7000 tutorial book for blinking LEDs and controlling the switches, gotten no errors in Vivado and SDK but no leds come on. Then I tried the "hello world" project and it failed to recognize the "xuartps.h" header. So that threw an error and nothing would be printed on the console. When I manually configured the Zynq 7 Processing System to resemble that of the zc702 board from the tutorial, it would produce no errors but nothing is printed on the console. I tried a verilog project which only uses the PL and this time the LED was blinking. But I eventually need to use the PS. 

@Hayder, I tried that out and still get no success trying the tutorial on the Flashing LEDs in the Zynq Tutorial Book. I also tried a project (possibly yours) with only verilog and the LED did blink. But I need to use the PS. 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now