Jos

OpenScope Wifi re-connect doesn't work

Recommended Posts

Hi,

after setting up my OpenScope initially, it connected successfully to my home wireless lan and I could access it from the tablet or browser as expected.

Then, I disconnected the scope from power and tried to run in on a power bank. The blue light wouldn' stop blinking, so no connection to Wifi anymore. I re-attached to the computer assuming the power bank had not enough power, but also there the scope wouldn't re-connect to Wifi.

I checked my Fritz!Box if the channel had changed to something above channel 11, but it is a safe channel 1.

Any idea what may have happened here?

 

Thanks,

Jos

Share this post


Link to post
Share on other sites

Hey Jos,

Are you able to manually connect the OpenScope MZ to the wifi network through WaveForms Live?

When you setup the wifi connection the advanced section of the configuration page allows you to save the network settings and auto connect on boot.  These are checked by default, but I would check and make sure.

openscope-mz-wifi-autoconnect.png

 

-Kristoff

Share this post


Link to post
Share on other sites

Hi Kristoff,

thanks a lot for your reply; I did try to set up Wifi using WaveForms Live again and again, using different access points of my network, even a different (guest) network my Fritz!Box provides - the OpenScope didn't connect to any Wifi anymore.

I also checked all advanced parameters, all were set up correctly.

cheers,

Jos

Share this post


Link to post
Share on other sites

Are you able to scan for networks and see the results in WaveForms Live?  What version of the firmware are you using? 

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

Yes, scanning works, I can see all networks. Latest firmware available (as of Saturday) installed.

Update: it is version 1.37 which is the latest according to WFL. See attached screenshots for firmware and Wifi.

Bildschirmfoto1.png

Bildschirmfoto2.png

Bildschirmfoto3.png

Edited by Jos

Share this post


Link to post
Share on other sites

update:

  • I tried hot spot mode of my tablet and OpenScope connected successfully to it.
  • I changed SSID of my Fritz!Box to something without an "@", to no avail.
  • I changed encryption of the Fritz!Box from "WPA+WPA2" to "WPA2 (CCMP)" - it connected! At least it got an IP address and red and orange LEDs blinked. But WFL on a tablet or from browser wasn't able to connect to this IP address.
  • I then tried the 3rd encryption option "WPA (TKIP)", again to no avail, no IP address, no connection.

So, my conclusion is that either firmware or even the Wifi chip itself are not capable of connecting to a Fritz!Box, at least mine (model 7390). I just wonder why it did connect at the very first try, but then refuses to connect to the very same network afterwards.

Is there any way to extend compatibility on the firmware level?

Edited by Jos

Share this post


Link to post
Share on other sites

Hey,

The OpenScope MZ supports WPA2 so I would expect both of the security settings you listed above to work.  When you change the router to WPA2 (CCMP) are you able to connect to the network and power cycle the OpenScope and reconnect reliably?  If so I'd be interested in staying in that mode to debug the connection issue from WFL.

I'm not familiar with the Fritz!Box (other than the quick google search I just did).  Is there anything unique about it?  I would be surprised if OpenScope MZ was not able to connect to a router that supports 802.11g and WPA2 unless there is some other configuration issue or unique 'feature' of the router.

-Kristoff

Share this post


Link to post
Share on other sites

Hi Kristoff,

sorry for the delay. Wasn't able to do further testing as per your suggestion but will do so on the weekend, hopefully.

But for completeness I can try to answer your question from the other thread out of my head:

  • Can you provide some details about the network:
    • Does it broadcast the SSID (ie is the network visible when you scan?) - yes
    • What is the SSID (are there any special characters like spaces, etc)? - 14 characters containing one "@"
    • What encryption type does the network use? - WPA2 CCMP/TKIP, PSK
  • How are you powering the OpenScope? - both power bank and 2A power supply
  • Is there anything unique about your setup?
    • Lots of wifi noise, unique network setup, etc? - 2 ESSIDs managed by one FritzBox and 2 LAN connected repeaters

Share this post


Link to post
Share on other sites

No worries Jos.

I'd be curious to see the console output during the boot process to see if it gives any more details on what happens when it tries to connect to the network:

Use WaveForms Live to setup your wifi connection.

  • Right click on the Digilent Agent and release the device.  This frees the COM port.
  • Use a serial terminal like PuTTY to open the serial port.  Set the buad rate to 1250000.
  • Press the reset button on the OpenScope MZ (the button farthest away from the wifi radio)
  • You should see boot up info printed to the terminal.
  • Here is what mine looks like when it connects to the 'Digilent_2.4G' network on boot.

image.png

-Kristoff

Share this post


Link to post
Share on other sites

I finally found time to debug as per your instructions, Kristoff:

--- snip ---

OpenScope v1.4.0
Written by: Keith Vogel, Digilent Inc.
Copyright 2016 Digilent Inc.

File Systems Initialized
MRF24 Info -- DeviceType: 0x2 Rom Version: 0x31 Patch Version: 0xC

USB+:     5010294uV
VCC  3.3: 3300360uV
VRef 3.0: 3001465uV
VRef 1.5: 1500732uV
USB-:    -4979611uV

Using calibration from: flash
Found parameter for AP: XXXXXXXXX@XXXX
Error Connecting to WiFi, Error: 0x90403E00

--- snap ---

I masked my wifi ESSID for security reasons, but it is plain lower case letters.

You may notice firmware version 1.4.0; after letting the device update to the latest version it claimed to be 1.296.0, I noticed that the offered firmware versions listed are sorted by plain numbers, so 296 is higher and therefore chosen by WFL as the latest; on the other hand the digilentinc.com website offers 1.4.0 as the latest. I now chose 1.4.0 and at least it already connected two times with the WIFI automatically, but in 99 out of 100 times it gives the above error.

Looking forward to your comments!

regards,

Jos

 

Share this post


Link to post
Share on other sites

Hi Kristoff,

I saw you released 1.296.0 to github, so I used this one in OpenScope assuming it is the latest - still, the effect is the same as mentioned above. Have you been able to find out the root cause from the posted debug actions or do you need more information?

cheers, Jos

Share this post


Link to post
Share on other sites

Hello 

I also cannot reconnect to wifi at home even after few restart. Did all the suggestions above and even saved on both sdcard and flash.

The only way is to always configure it every start then it would connect again to wifi.

Here is the serial datalog:


=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2019.02.09 09:43:24 =~=~=~=~=~=~=~=~=~=~=~=
^@OpenScope v1.301.0
Written by: Keith Vogel, Digilent Inc.
Copyright 2016 Digilent Inc.

File Systems Initialized
MRF24 Info -- DeviceType: 0x2 Rom Version: 0x31 Patch Version: 0xC

USB+:     0uV
VCC  3.3: 3313321uV
VRef 3.0: 3001465uV
VRef 1.5: 1500000uV
USB-:    -4824034uV

SD card detected and mounted
Using calibration from: flash
Unable to connect to WiFi AP. Error 0xA000001B

Enter the number of the operation you would like to do:
1. Enter JSON mode
2. Calibrate the instruments
3. Save the current calibration values
4. Manage your WiFi connections
5. View all files names on the SD card
6. View all files names in flash
7. Set the Oscilloscope input gain

 

Share this post


Link to post
Share on other sites

Hi @victagayun,


When your OpenScope starts initializing the WiFi state, it is reporting a WiFiNoNetworksFound error. Even though you've asked it to save the credentials, the auto connect may happen to fail for several reasons. When a connection attempt fails, the OpenScope only knows that it's disassociated based on the response it gets back from the radio and doesn't retry.

One cause of failure may be due to the signal. On a network with many connected devices the routers are increasingly busy and can't service all the traffic. If the OpenScope were on such a network, it may fail to connect to the access point. If possible, try connecting to a network with less traffic, or a stronger signal.

Another possibility is that the credentials you've entered are wrong. Because the OpenScope only knows it is disassociated when it fails to connect, it cannot recognize that a connection attempt failed because of incorrect credentials and not because the network is busy. If you double (triple) check the passphrase you used, you should first delete the connection entry from the OpenScope, then proceed to entering the credentials anew.

Share this post


Link to post
Share on other sites
Quote

When a connection attempt fails, the OpenScope only knows that it's disassociated based on the response it gets back from the radio and doesn't retry.

Why it doesn't retry few times? In Arduino ESP8266 you would try to add few time of tries and timeout, why not do the same?

Quote

One cause of failure may be due to the signal. On a network with many connected devices the routers are increasingly busy and can't service all the traffic. If the OpenScope were on such a network, it may fail to connect to the access point. If possible, try connecting to a network with less traffic, or a stronger signal.

This PC I am using is just 1m below the router. The shelf above where the router is, is just 1m above this PC and the Openscope. That means that the Openscope is about a meter from the router.

I am using Linksys AC1900 (Max Stream EA7500) Dual Band Wireless Router 2.4Ghz and 5Ghz with only 5 devices connected.

Quote

 If you double (triple) check the passphrase you used, you should first delete the connection entry from the OpenScope, then proceed to entering the credentials anew.

I don't need to do that. When I go to configuration menu, I just click the "saved network", it would connect right away. That means my credentials are all OK.

It could be a problem in the field when using it without a USB connection to connect it to wifi.

That means that I need to bring a laptop to configure it while on USB just to connect it to wifi. But when I unplug it expecting that it would connect to wifi, it would not.

Then I would connect it again to a laptop to configure it to connect on wifi. Instead of just bringing a tablet, I would need to bring an extra laptop.

Edited by victagayun

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now