• 0
kpax

Cannot talk to Arty board with Vivado 17.2

Question

I have not been able to program anything on my ARTY board. I have re-installed Vivado 17.2 several times to make sure the "cable drivers" were installed. I am running the non-HLS version of Vivado 17.2.There is talk about this plug-in tool on the website:

http://store.digilentinc.com/digilent-plugin-for-xilinx-tools-download-only/

It implies that it allows Xilinx software tools to directly access Digilent USB-JTAG circuitry across Xilinx tool versions 11, 12, 13, and 14. So does that mean that newer versions of the Xilinx software tools (Vivado 17.2 lets say) will not drive any of the “Digilent USB-JTAG circuitry”? I assume that all the newer boards like Arty, Arty Z7,  and Arty S7 also have this “Digilent USB-JTAG circuitry”. Or is this done differently?

Then as a prerequisite to this install is to install “Adept 2”.
https://reference.digilentinc.com/reference/software/digilent-plugin-xilinx-tools/start

 

This says it’s supported by Xilinx iMPACT (12.x, 13.x, 14.x only), Chipscope Pro, Xilinx Microprocessor Debugger (XMD), and EDK Software Development Kit (12.x, 13.x, 14.x only).What does this do?Then there is there is the driver for virtualizing the serial port which is part of the “Digilent USB-JTAG circuitry”.
http://www.ftdichip.com/Drivers/D2XX.htm

Can someone please tell me which of these are necessary to get Vivado 17.2 to talk to the Arty board? Can someone please tell me which order these have to be installed?

Thanks everyone...

Running:
Win7 Professional.

 

In particular, I cannot see the Arty board when I open the hardware manager in Vivado 17.2

image.png.46f7e9501459c42e9b4f508168c25a0e.png

Edited by kpax
Additional information

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Hi kpax,

am running Vivado 2017.2 with both Arty A7 and Arty Z7 boards ok. I suspect that later Vivado versions are shipping with the Digilent driver support built in. I did not 'add' drivers to make it work.

Have you clicked on 'Open Target' (blue text in your screenshot)? When I do this I get a menu, I then click 'Auto Connect' and my board shows up.

Cheers,

Stephen

Edited by Stephen D

Share this post


Link to post
Share on other sites
  • 0

9/21/2017

Hi Stephen, That’s good to know, perhaps I have to uninstall everything and simply do a fresh install of Vivado 17.2. Did you have to install any of the FTDI drivers for the USB port?

To answer your question:

 

Before clicking on “Open target”

image.png.35d62a9dc29c4ec1e7e5afc1f27bd20e.png

After clicking on “Open target > Auto Connect”

image.png.97c36a6d5a0b01bfd35a8542260205bb.png

What I’m suspecting is happening here is that the local hardware server is connected properly with Vivado but the local hardware server is not properly connected with the target, meaning the USB connection to the Arty board.

When I look at Device Manager as I plug in the Arty board I see…

Before:

image.png.c441b249ad7e5b2b758ff8e3acf5733e.png

 

After:

image.png.40ebb35b8d61bf0a070bb858e07995f2.png

 

It looks like 2 endpoints were established after the USB enumeration but the Local Hardware Server doesn’t recognize them. I believe the FTDI chip is the heart of the “Digilent USB-JTAG circuitry” and that the idea is to make the “Digilent USB-JTAG circuitry” appear like a serial port to the system.

Not sure where to go from here…

Share this post


Link to post
Share on other sites
  • 0

Hi @kpax,

Are you able to program other boards or see data from a compatible smart phone with the USB A to Micro-B cable you are using?  Concerning the FTDI drivers, the FTDI drivers should have downloaded and installed the first time you connected the Arty to your computer. The FTDI drivers can be downloaded from here. Have you used another computer with Vivado? Please download Adept 2 here and see if this software can connect to your Arty(make sure Vivado is not connected to your Arty in any way). I have included some screen shots below. Also to clarify when you connect the Arty the power led ld11 turns on?

cheers,

Jon

Arty_connection_issues_3.jpg

Arty_connection_issues_2.jpg

Arty_connection_issues_1.jpg

Edited by jpeyron

Share this post


Link to post
Share on other sites
  • 0

As a follow on from Jon. Looks like the FTDI drivers haven't loaded/installed properly.

1) In the Windows Device Manager, double click on "USB Serial Converter A" & "USB Serial Converter B" -> a "... Properties" dialog opens

2) Open the "Driver" tab in one of the dialogs.

3) What happens if you click the "Update Driver..." button?

Share this post


Link to post
Share on other sites
  • 0

Stephen,

In both cases of "USB serial converter A and B", selecting update driver gives you the usual two options, Search automatically or Browse my computer. Searching automatically results in "The best software driver for your device is already installed". The other option I tried is ..\..\CDM v2.12.28 WHQL Certified\, this is where I un-archived the latest FTDI drivers. Selecting this results in the same message "The best software driver for your device is already installed”.

I have tried installing (and re-installing) VIVADO on three different computers now and made sure I have a good USB cable without any luck. The crutch of the problem is as Jon mentioned is that the server cannot find the target. When bringing up ADEPT2 I see this:

 

image.png.dab7e3db64ab96671a3056b92674f93e.png

Both VIVADO 17.2 and SDK 17.2 find the hardware server Ok but the hardware server can’t find any targets.  This is extremely frustrating as I have lost customers because I simply cannot get anything accomplished. This goes back to Zynq projects that never materialized because of these same issues. What was wrong in the way all this stuff used to work when we used a serial port or USB port? What is this added complexity with a “Hardware Server” anyways?

Here’s a thought, can I go back to using my Xilinx “Platform Cable USB” cable to talk to the ARTY board? Does anyone know if Vivado works with it?

 

 

Share this post


Link to post
Share on other sites
  • 0

HI @kpax,

I am sorry to hear you are still having issues with connecting the Arty Artix 7 development  board. Since Adept 2 is not able to see the Arty this leads me to believe that this is an EEPROM issue. I am tagging the engineer that handles this issue( @Bianca).  The Xilinx Platform cable USB should work with Vivado as long as the EEPROM is correctly working.

cheers,

Jon

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Bianca said:

Hi @kpax,

You have a private message.

Best regards,

Bianca

Hi Bianca,

Thank you for responding….

I did what you said to do on my Laptop which is the computer I am trying to get the Arty board working on. The FTDIconfig program did not find the Arty board when “Find Devices” was pressed. I checked the dropdown box in step 2 but there was nothing there. I pressed “Get Info” and a box popped up saying “Failed FT_OpenEx”. I tried several other known good USB cables as well. Nothing seemed to work.

1.png.58c9a7fcdbaf4b0632a9c0c9f4e0e53b.png

I then tried doing this on my Desktop computer which originally also couldn’t find the Arty board. My Desktop Computer did find the Arty board and I managed to initialize it properly as per your instructions.

3.png.c33f532dd6b3b60c679ea3b7835e0fc6.png

I ran the Adept2 program and it does now seem to find the Arty board correctly. I also ran the hardware manager in Vivado 2017.2 and it also found the Arty board correctly.

4.png.d9fcb0769079a44c4d0bd874824a47d7.png

So, plugging the Arty board back into my Laptop, the laptop (Win7Prof-64bit, IntelI7 8core) now recognizes the Arty board with this message below.

5.png.8d9f9b9d9facd0d53fa8277738ee3293.png

Monitoring “Device Manager” when plugging in the Arty board I see this:

6.thumb.png.5b3a12a9fba53721b307547bc74e6cd3.png

Note that “WinDriver”, “USB Serial Converter A” and “USB Serial Converter B” have the yellow sign on them. I am not sure where to go from here.

Thank you very much for getting me this far. AT least I can get going on my desktop computer.

-Kpax

 

 

Share this post


Link to post
Share on other sites
  • 0

@kpax,

It seems you have an issue with the drivers on this one. Sometimes when you install Vivado the drivers don't install correctly. So, if you have vivado Installed, please try to install manually the drivers. Here is the path to file the cable drives, It's the same on each installer: C:\Xilinx\Vivado\2015.4\data\xicom\cable_drivers\nt64\digilent I have a previous version of Vivado, you'll have 2017.2

Please try this and if it's not working we'll see if there's anything else we can do

Best regards,

Bianca

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Bianca said:

@kpax,

It seems you have an issue with the drivers on this one. Sometimes when you install Vivado the drivers don't install correctly. So, if you have vivado Installed, please try to install manually the drivers. Here is the path to file the cable drives, It's the same on each installer: C:\Xilinx\Vivado\2015.4\data\xicom\cable_drivers\nt64\digilent I have a previous version of Vivado, you'll have 2017.2

Please try this and if it's not working we'll see if there's anything else we can do

Best regards,

Bianca

Bianca,

I tried manually installing the drivers, but nothing changed. The Device Manager looks exactly the same as before. One thing I'm curious about is the Jungo>WinDriver. This stays that way no matter if any USB cables are plugged in or not. I think Xilinx tools installs this as part of their installation.. I'm not sure. Can or should this be re-installed?

Thanks for the help....

Share this post


Link to post
Share on other sites
  • 0

I have a Zynq ZC706 board and I'm having this exact issue.  The digilent drivers don't install correctly.  I've tried several methods including running the wrapper.bat file and using wdreg directly.  The problem seems to be with the windrvr6 driver file.  If I try to install the latest adept, I get an 80030000 error.  Using wdreg I get access is denied errors copying the inf file.  But I'm running from an administrator cmd prompt.

C:\Windows\inf>f:wdreg -compat -inf f:windrvr6.inf install
WDREG utility v10.21. Build Aug 31 2010 14:21:54

Processing HWID *WINDRVR6
Installing a signed driver package for *WINDRVR6
Error: Failed to install the INF file (F:\Xilinx\Vivado\2017.2\data\xicom\cable_
drivers\nt64\windrvr6.inf)
Warning: cannot copy INF file F:\Xilinx\Vivado\2017.2\data\xicom\cable_drivers\n
t64\windrvr6.inf to the INF directory: Access is denied.

Warning: cannot copy the INF file for device (hwid:*WINDRVR6): Access is denied.


Error updating the driver (hwid:*WINDRVR6) with the INF file: Access is denied.

Error: Failed trying to install the driver

I'm not trying to hijack this thread - just providing more info.  Thanks, Ryan

Share this post


Link to post
Share on other sites
  • 0

@kpax

It sounds like the Arty is working correctly on your desktop so we can rule out any EEPROM image issues, as well as any issues with the actual hardware. SInce this appears to be an issue with the FTDI driver not attaching correctly to the device re-installing Vivado over and over isn't going to help resolve the issue. I see you already tried updating the driver and that doesn't appear to have worked because Windows thinks it's the same driver that's already installed. Have you tried doing the following:

1. In the device manager under USB devices right click on “USB Serial Converter A” and click “Uninstall”. Do the same for “USB Serial Converter B”.
2. Disconnect the Arty from the PC
3. Reboot, reattach the board, and see if the driver gets properly installed/loaded

If that doesn't work then another option is to disconnect the ARty board from your PC and then use FTDI's CDM Removable tool to uninstall the driver. They don't appear to have updated the tool in quite some time but it's still available for download from their website:

http://www.ftdichip.com/Support/Utilities/CDMUninstaller_v1.4.zip

If you want to try this disconnect the Arty board, run the application as an Administrator and put in “0403” for Vendor ID, “6010” for product ID and then click “Add”. After that click “Remove Devices”. Reboot and re-attach Arty board to PC with USB cable. This does a more thorough removable than just uninstalling the driver from the Device Manager, so I suspect you may get better results when reinstalling the driver.

If none of the above works then perhaps try a different USB cable and/or different USB port.

Thanks,
Michael

Share this post


Link to post
Share on other sites
  • 0
On 10/12/2017 at 10:30 PM, kpax said:

Bianca,

I tried manually installing the drivers, but nothing changed. The Device Manager looks exactly the same as before. One thing I'm curious about is the Jungo>WinDriver. This stays that way no matter if any USB cables are plugged in or not. I think Xilinx tools installs this as part of their installation.. I'm not sure. Can or should this be re-installed?

Thanks for the help....

@kpax, were you able to resolve your issue with this? I've having very similar difficulties.

 

Best,

Derry

Share this post


Link to post
Share on other sites
  • 0

Hello all,

I had the same issue with the ARTY-S7 board. The solution for me was to enable 'Load VCP' in the Advanced tab of the USB Serial Converter B properties.

image.png.575d675aeaca35c7628625e389d495f3.png

Maybe this helps somebody in the future.

You're welcome,

 - Wolfgang.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now