• 0

Still no terminal messages from Zybo


Question

I started this post

and got a good response. I was able to use jpeyron's project (Hi Jon) to get the Zybo Getting Started to turn on LEDs with the switches.

However, I still cannot get any output on any console. I am sticking with his project until I get this console business sorted out.

Here's what I have:

Vivado 2016.4 on a 64-bit Ubuntu 16.04. I'm trying this:

https://reference.digilentinc.com/learn/programmable-logic/tutorials/zybo-getting-started-with-zynq/start

and I do indeed have the correct board activity (LEDs and switches).

On power on, I see this:

[email protected]:~$ lr /dev/ttyU*
ls: cannot access '/dev/ttyU*': No such file or directory

turn on the Zybo and:
[email protected]:~$ lr /dev/ttyU*
crw-rw---- 1 root dialout 188, 1 Sep 14 18:08 /dev/ttyUSB1

So it looks like it's ttyUSB1.

I am in the dialout group.

I have tried, minicom, screen, putty, and cutecom, all with /dev/ttyUSB1, 115200, 8, none, 1, and I've played around with the flow control.

If I type anything in the console I see the Zybo board's TX led flash. So it's the right port and I can program the board, and the SW is running on the Zynq. But I never get anything out on the console. The "getting started" is meant to tell me via the console which button I pushed (and that's something I so want to know).

I have read and tried about 20 different "solutions".  Any help appreciated as I have had zero success.

Specific question: For anyone else with Vivado 2016.4 on a 64-bit Ubuntu 16.04, have you had to install the Digilent Adept SW to get this working?

Any help appreciated as I have had zero success and for the first time in my many years I'm thinking about Altera.

GogMagog

 

 

Edited by GogMagog
Correction
Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I said "Altera" and pushed a button and it worked.

OML.png.321a00cde3390722a6f79a88d5aa2b36.png

No seriously, I got it working and I will put here what I did at the end in case it helps others. The problem is that I tried to follow a procedure to manually install Digilent Programming Cable drivers and the Digilent Adept run-time SW, this one:

https://www.xilinx.com/support/answers/54382.html

but the procedure is not correct for my system (Vivado 2016.4 on a 64-bit Ubuntu 16.04), so I had to abandon it. Nonetheless, that seems to have made the difference.

1) I downloaded the tarball digilent.adept.runtime_2.16.6-x86_64.tar.gz and for lack of direction I dropped it in my home dir. Unzip and untar.

2) Create a /tmp/digilent_install directory.

 664  mkdir /tmp/digilent/SDK
 665  mkdir /tmp/digilent/Vivado

3) Copy the /<Xilinx install>/bin/lin(64)/digilent directory to the newly created /tmp/digilent_install.

Nope. No such directory. I took this guess:

  667  cp -rf /opt/Xilinx/SDK/2016.4/data/xicom/cable_data/digilent /tmp/digilent/SDK/
  669  cp -rf /opt/Xilinx/Vivado/2016.4/data/xicom/cable_data/digilent /tmp/digilent/Vivado/

4) cd digilent.adept.runtime_2.16.6-x86_64
./install.sh silent=1
cd ..
cd ftdi.drivers_1.0.4-x86_64
./install.sh silent=1
cd ..
- cd libCseDigilent* - ./install.sh silent=1

OK no. There is no libCseDiglient. Not even here:

find / -name \*libCseDiglient\*.

There is a digilent.adept.runtime_2.16.6-x86_64/lib64. But, I did not continue with the process.

Again, that's half of an install procedure that seems to have made a difference. You tell me.

GogMagog

Edited by GogMagog
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now