Basic I/O Shield and LEDs


Recommended Posts

  • 2 months later...

I just approved a comment/question on the blog regarding the Basic I/O Shield post, and I was wondering if you could help out with an answer:

 

"This is very cool!!

I just got this kit and I just tried the First two programs here on this pages to verify the that the board works and it does!!
Thank you for posting this!!

However I can not get the OLED Demo to work to verify that the display works.
Can you post a program that I can copy and paste like the other one for the OLED?

I did everything I was supposed to do I believe that is correct as described from the CHIPKIT website and your video (using Windows instead) tutorial using the demo file from Diligent and it fails to work.

I get a compilation error, so it never gets to the point to upload the program to the uc32.

Many of the other demos work as well so I know the uc32 is working properly.
I just got this so I need to verify that if the OLED is working or not, in the case if that I need to send it back to the supplier.

Thanks!! Jer icon_biggrin.gif"

Link to post
Share on other sites

It looks like on the blog there was a reply from JColvin, however to echo that. 

 

First, the jumper settings need to be verified .

The other is that if they are using my demo code in the blog post, I didn't use any libraries, so they will need to make sure that they are including the OLED library in their code. 

 

If possible, let us know the error s(he) is getting, so we can track down a more specific answer!

Hope that helps!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now