• 0
stewart

arty not auto-loading from flash. must push "PROG"

Question

I have successfully used Vivado to store the bitstream into flash.  On power-up, however, it does not program itself.  If I push the PROG button, it does load the program from flash.  That takes about 6 seconds.  Two questions:

1. how do I get the program to auto-load?

2. how can I get it to load faster? the default program from Digilent loads in under a second.

Thanks!

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

adding this to the top of my .xdc file made it load from flash a lot faster:

set_property BITSTREAM.GENERAL.COMPRESS TRUE [current_design]
 

Share this post


Link to post
Share on other sites
  • 0

Hi @stewart,

Compressing the bitstream makes a big difference in the time it takes to load from flash. Have you looked at our tutorials: here(flash loaded through sdk) and here(flash loaded through vivado). Are you powering the Arty through the usb or externally? If you are powering it through the usb are you unplugging the usb and plugging it back in with JP1 set to quad spi flash and it is not loading? 

thank you,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron,

I'm using Vivado on Linux and the interface is slightly different.  There is no "additional options" link to enable compression, sadly.  I've added the compression option in my .xdc file and that's working.  I'm not using the Microblaze core, either.  Just straight up verilog.  I'm powering Arty via J10.  I have JP1 jumped.  It's inconsistently loading the program on power-up.

Thanks

Share this post


Link to post
Share on other sites
  • 0

Hi @stewart,

Please attach a screen shot of what selection you have when you click on project setting on the top left of your Vivado 2017.2. I have included screen shots of what I see in the windows version. You have to run the synthesis and then open the Synthesized Design. Once you have done this then go to the main toolbar select Tools -> Edit Device Properties. I have included a screen shot. Could you please include a screen shot as well. This tutorial here walks you through this process.

thank you,

Jon

arty_compression.jpg

arty_compression_2.jpg

Edited by jpeyron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now