• 0
hamidelectrical@gmail.com

SRK + LINE not working

Question

I purchased two SRK + LINE robotic kit and assembled it according the procedure provided on the website, but still none of it is running. What could be the possible errors. Kindly help me.
 
Thanking You
Edited by Josh
Added Tags

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi Hamid,

 

I think I found the potential issue that you're running into, which for some reason is not mentioned at all inside the provided manual. 

 

The PmodLS1 has the small orange/yellow knob that is the gain factor for that Pmod and controls the sensitivity of the sensors. If it is rotated too far to one side or the other the sensors will be either too sensitive so that they are always on or too insensitive so that they are always off. I would try rotating the knob until those four LEDs on the PmodLS1 turn on again, indicating that they are sensing the infrared being reflected off the white(ish) floor. This should hopefully make your robots turn on since the code only lets the robots turn on when the button is pressed or if some of the light sensors are sensing something. Everything else about your design seems to be done perfectly.

 

Let me know how it goes.

 

Thanks,

JColvin

 

Hi JColvin

 

Thanks bro..

After increasing the sensitivity and interchanging the motor the robot is running.

 

Thanks again for your help.

 

Hamid

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

When you say it is not running, what do you mean? Are the motors turning on but the wheels aren't turning? The robot doesn't turn on at all? Did you program the chipKIT MX3 board through MPIDE? 

 

If you can post a photo of your setup, that would be great.

 

Thanks,

 

JColvin

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

When you say it is not running, what do you mean? Are the motors turning on but the wheels aren't turning? The robot doesn't turn on at all? Did you program the chipKIT MX3 board through MPIDE? 

 

If you can post a photo of your setup, that would be great.

 

Thanks,

 

JColvin

 

Hi JColvin,

 

Thanks for reply.

I assembled the kit according to the manual provided on the website ( here is the link https://www.digilentinc.com/Data/Products/SRK-LINE/SRK-Line_rm.pdf  )

I programmed the CEREBOT MX3ck using MPIDE. The program code used was the same as provided on the website ( here is the link https://www.digilentinc.com/Data/Products/SRK-LINE/SRK+Line.zip ). here are some snap of the setup.

20150402_085944.jpghttp://www.mediafire.com/view/7o3oeegyvct3rmr/20150402_085944.jpg

20150402_085958.jpghttp://www.mediafire.com/view/ummlm0b01pckc3x/20150402_085958.jpg

after pressing the BTN2 nothing happens, the robot doesn't turn at all and also the 4 LEDs of PmodS1 is not glowing. I don't know where is the error.

 

Thanking You

 

Hamid

Share this post


Link to post
Share on other sites
  • 0

Hi Hamid,

 

I think I found the potential issue that you're running into, which for some reason is not mentioned at all inside the provided manual. 

 

The PmodLS1 has the small orange/yellow knob that is the gain factor for that Pmod and controls the sensitivity of the sensors. If it is rotated too far to one side or the other the sensors will be either too sensitive so that they are always on or too insensitive so that they are always off. I would try rotating the knob until those four LEDs on the PmodLS1 turn on again, indicating that they are sensing the infrared being reflected off the white(ish) floor. This should hopefully make your robots turn on since the code only lets the robots turn on when the button is pressed or if some of the light sensors are sensing something. Everything else about your design seems to be done perfectly.

 

Let me know how it goes.

 

Thanks,

JColvin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now