• 0
Sign in to follow this  
c64

MPIDE can't find h files

Question

Hi,

 

I just bought the Chipkit Wi-Fire board and trying to use the DEIPcK examples that are provided on Digilent's website in MPIDE. However, when I try to compile an example program, for example WiFiScan, I get the following error message:

 

WiFiScan.cpp:55:101: fatal error: MRF24G.h: No such file or directory
compilation terminated.
 
MRF24G.h is the first h file that the program tries to load. I've included the DEIPcK libraries in the way that is described on this website: http://chipkit.net/started/learn-basics/party-libraries/
 
Any suggestions?
Edited by KaitlynFranz
Added Tags

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi c64,

 

It was recommended to me that you try downloading one of the newer MPIDEs from 2015-01-30 or newer. These apparently have the MRF libraries incorporated into them.

 

Let me know if you have any more questions.

 

Thanks,

JColvin

Share this post


Link to post
Share on other sites
  • 1

Hi,

 

I just downloaded the newest release from the link you sent me, and now it works like a charm! Thanks!

Share this post


Link to post
Share on other sites
  • 0

Hi c64,

 

That website does describe the correct way to get any downloaded libraries accessible for MPIDE, and I presume that you included all 5 libraries that came in the deIPck zip file.

Did you make sure to close out and restart MPIDE so that it can find the newly placed files?

 

Thanks,

JColvin

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

Yes, I created a folder Libraries in my mpide folder. Inside Libraries I placed the unzipped delPck folder, which contains all 5 libraries. I've restarted MPIDE, as well as my computer, and I can access all the examples from the menu, so it seems as if the libraries have been included properly. But I still can't compile, still getting the same error message. If I place the MRF24G.h file in the same folder as the MPIDE project, and change the line to #include "MRF24G.h" (instead of the  <> enclosure signs), the error message now refers to the second h file that is supposed to be included. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this