• 0
HansV

Logic Protocol triggering versus Simple triggering

Question

Hello,

I think the latest waveforms software is fantastic. However, I still have a problem with triggering, specifically protocol triggering. In the enclosed screenshot, I have a UART and OneWire and a SPI protocol decoder. If I choose Simple triggering, everything is ok, but if I choose Protocol-UART-TX-GPIO1 (UART decoder form the Protocol selection button pull down menu) then the OneWire and SPI decoders trigger-selection-arrows switch too! What I would like is that I can only choose the UART OR only the OneWire OR only the SPI decoder as suggested by te Protocol selection button pull-down menu. So I can see where I am triggering on.598d55c90ab41_UARTTX-RX.thumb.png.522185406832a5655097d04dadddf51b.png

Am I right? or is what I ask impossible? Thanks in advance, Hans.

 

Edited by HansV

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

What i am trying to do here is to measure all signals on a WEMOS d1 mini stack with SD card, DHT sensor and a Relay and a LED all switched by an onboard webserver-web page. This is a IOT project as you can guess.

Share this post


Link to post
Share on other sites
  • 0

Hi @HansV

Thank you for the you observation.
I wanted to modify the protocol trigger for the current version similar to this but had no time for it, I hope to make it for the next version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now