• 0
scud

waveforms 2015

Question

hello everyone newbie.

i recently bought a discovery2 usb scope, to record mains power data and then write that data to excel .

i'm stuck with two problems i have and hopefully some with more experience could help .

the first is the logger within the waveforms 2015 program saves files or aquisitions to a maximum of 9999 . and at the rate i'm required to sample means i can only record approx 18 minutes of data , is there a way to lift the number of index files to 20,000 , this is the logger view within the scope window of waveforms 2015  ?

the second problem i have is the the logger does write files to exel, but it logs the time to show year,month,day .then hours minutes, and seconds .(GMT +1 hour).(DAYLIGHT TIME) 

i could really do with the log to read milliseconds as well . is there a way to write the javascript to do this ,, tried for many hours TRIED . FAILED. 

any help with these would be great 

many thanks all 

best setting.png

openoffice spreed.png

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi Attila

Thank you so much for your reply..i will try the JavaScript you suggested I'm sure it will work ..thats great .

The logger you mention in your reply..i did try that one .it was great .however I'm unable to select frequency to at least 3 decimal places... 

That is why I was using the logger in the scope window ..thats perfect but requires more index acquisitions.. 9999 gives me about 18 minutes at 100ms .

20000 would give me more than 30 minutes at 100ms 

Many thanks again

Share this post


Link to post
Share on other sites
  • 0

Hi @scud

In Logger/Voltmeter the update rate determines the RMS frequency limits.
The 2nd AD configuration under Settings/Device Manager provides 16k buffer for Scope channels and this doubles the RMS frequency range.
 

Share this post


Link to post
Share on other sites
  • 0

Thank you once again Attila. 

The time stamp worked perfect ..i will look into the setting in device manager when I'm next in the workshop. 

Many thanks for your experience 

Scud 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now