• 0
gutielo

XADC working without power supply?

Question

Posted (edited)

Hello guys.


I was wondering how it is possible that the XADC in the Zedboard does actually convert data even though I didn't feed it with 1.8V power supply? I mean there is a physical pin but I'm not using it, so the XADC shouldn't work but it actually does. How come?
Thanks.

 

Edited by gutielo

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Hi @gutielo,

If you look on page 11 of the Zedboard schematic here you will see that 1.8V is being connected to XADC-VCC.

cheers,

Jon

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Hi @gutielo,

I have reached out to one of our layout engineers to get more specifics about the 1.8v pin. I might be a couple of days to get you a response.

cheers,

Jon

Edited by jpeyron
gutielo likes this

Share this post


Link to post
Share on other sites
  • 0

Hi @gutielo,

I have reached out to our Layout engineer. They are currently out of the office. When they get back I will get you a response. I am sorry for the inconvenience.

thank you,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @gutielo,

I reached out to one of our design engineers. What i found out is that the pin is an output and intend to power a peripheral board. The XADC itself is powered via the VCCADC on the Zynq, which is powered by an onboard regulator. We followed Xilinx’s spec for the header so it’s more or less the same as the XADC header on any of Xilinx’s series 7 evaluation boards. The design engineer believes the purpose of this particular pinout was to make it compatible with the following board: https://www.xilinx.com/products/boards-and-kits/hw-ams101-g.html. Sorry about the delay. 
 
cheers,
 
Jon
gutielo likes this

Share this post


Link to post
Share on other sites
  • 0

@jpeyron

Thank you very much! So as I expected, it was an output pin just like Vref. Then it is impossible that getting a temp conversion of -273.1ºC is because there's no power supply. I'll keep on doing more research.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now