tsenneville

Openscope not installing

53 posts in this topic

Greetings!

 

I have received my Openscope and was trying to get it installed but it is not being recognized by my 32 Bit Windows 8.1 machine and, therefore, not loading the drivers.

Any thoughts?

Share this post


Link to post
Share on other sites

Hey Tsenneville,

Does the OpenScope MZ show up in device manager?  Windows 8 should automatically install the drivers for you and the OpenScope should show up under Ports but if Windows cannot find the correct driver for some reason the OpenScope MZ will likely show up with a yellow exclamation mark on it in device manager.

If you're missing the drivers you can download them manually here and then use device manager to point the OpenScope MZ at the correct driver.  Let me know if you need details on any of this or have any other questions.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

OK. I have downloaded the drivers.

When I connect the open scope to my computer, it beeps like I have plugged in a USB device but the only place in Device Manager I can find any reference to the open scope is that it appears as COM 4 and when I look at the driver information, Windows tells me that the Device is working properly yet neither Waveforms or Waveforms Live recognizes the open scope.

What should I do next?

Share this post


Link to post
Share on other sites

One other question...

 

Does the board have an LED that lets one know if it is getting power or some other indication that the board is alive?

Share this post


Link to post
Share on other sites

Hey tsenneville,

The OpenScope MZ should show up as a COM device so that is good.  The full setup instructions are here.

  • Did you install the Digilent Agent?  You'll need it to connect to the OpenScope via USB.
  • If you already have the Digilent Agent installed, what version is it?  You can see this by right clicking the Digilent Agent icon in the system tray (by the windows clock).  One of the menu items will list the version.
  • Just to clarify OpenScope MZ will not show up in WaveForms, it can only be added to WaveForms Live.

Once you update the firmware to 1.4 or newer the board status will be indicated by the blue LED.  The Blue LED will flash once the board has booted and the instruments are ready and will be solid blue if the OpenScope MZ is connected to a Wifi network (the network connection is always established after the instruments are ready).  If the board is not configured for Wifi the blue light will continue flashing.

-Kristoff

Share this post


Link to post
Share on other sites

Yes, I did install the Digilent Agent (Version 1.00) but when the program runs (Waveforms Live) none of the screen functions (Add Device, Menu, Getting Started or Tutorial) work.

There is a jumper on the open scope labeled USB/Prog...where should that jumper be positioned?

Also (I hate to sound dense) how do I get the drivers loaded...there is no Install file...just the drivers?

 

Tony

Share this post


Link to post
Share on other sites

Hey,

If the OpenScope MZ shows up in device manager as a COM port then the drivers are installed and working.  Windows typically finds these for you.  You can make sure by unplugging the OpenScope MZ from the computer and reconnecting it and confirm that the COM port goes away in device manager and then comes back once you reconnect the device.

What browser are you using.  We highly recommend Chrome for WaveForms Live but it should work well in Firefox and Safari as well.  WaveForms Live works in current versions of Edge as well but a few menus might look a little funny.  Internet explorer is not supported.

You can check out the videos in the getting started guide to see how thing should look as you go through the first time setup and we have additional videos on youtube here.

-Kristoff

Share this post


Link to post
Share on other sites

OK. I have Waveforms Live up under Chrome and I can Add a Device.  I click in Add Device and choose http://localhost:42135. When I hit the "+" sign to add the device I get the error, "Error connecting to the Digilent Agent. Please make sure the Digilent Agent is Running".  It IS running and I have set Chrome to be the default browser.

This seems like a lot of effort for something that should just work.  I must be doing something wrong.  When I downloaded the drivers I did get the 32 bit drivers (my version of Windows 8.1 is 32 bit).  I am wondering if the wrong drivers were used by the system when I first plugged the Open Scope into the computer.

I watched the first video on installations but it does not really go into what to do if the installation does not work.

 

Any other suggestions?

Share this post


Link to post
Share on other sites

I'm 95% certain your drivers are fine.

At this point it sounds like the connection between the browser (WaveForms Live) and the Agent is being blocked.  Can you temporarily disable all firewalls on your computer (the windows firewall and any 3rd party file wall / virus scanner) then try to add the Digilent Agent to WaveForms Live again.  If that works we can add specific exceptions for the Digilent Agent.

-Kristoff

Share this post


Link to post
Share on other sites

WEBROOT firewall, Runtime Shield and WEB Shield OFF

Windows Firewall OFF

No Change.

I have attached a screen grab of the Driver Information for the device connected as COM 4 (The Open Scope). Are these drivers correct?

Capture.JPG

Share this post


Link to post
Share on other sites

Any other suggestions?

 

What could possibly be stopping the Digilent Agent from finding the Open Scope?  I disabled WEBRoot and the Windows Defender but it made no difference.

 

My system is as follows:

ASUS X205t

Windows 8.1 32 Bit / 2 Gig Ram / ATOM 3735F Proscessor / 16 Gig flash drive with 2.18 Gig Free Space

WEBRoot Anti Virus (Turned OFF)

Windows Defender (Turned OFF)

Digilent Agent Version 1.00

 

The Open Scope appears in the Device Manager as COM 4 and the drivers are shown in a previous email.

 

I have used the PC for: 3D Printing (Rambo 1.2), Arduino programming (using a variety of Arduino-based boards) and another PC based Ocilloscope, ALL without any problems and with the anti virus and defender running.

 

Please Help!

Share this post


Link to post
Share on other sites

Hey,

Let's confirm that the drivers are working and that the issue is WFL connecting to the agent.

Can you:

  • Connect the OpenScope MZ to the PC via USB.
  • Right click the agent and make sure active device is grayed out.  If it is not, select the device and release it.
  • Use PuTTY or Terra Term to open the COM port associated with the OpenScope with a baud rate of 1250000.
  • Press the reset button on the OpenScope MZ (The button farthest from the wifi radio).
  • You should see a boot message like the following.  Let us know what you see there.

If this works we can rule out the FTDI driver and focus on the WFL to Agent connection.  If not we need to get those drivers working.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

OK.  I have downloaded Terra Term and installer it.

I have run Terra Term and picked COM 4 (The Open Scope)

I have gone to the Setup Menu and picked "Serial Port" but the highest setting I can pick is 921600.

 

Next?

 

Share this post


Link to post
Share on other sites

You can manually type other buad rates that are not in the drop down in terra term.

-Kristoff

Share this post


Link to post
Share on other sites

Great!  That confirms that the drivers are working.  Now the issue is getting WaveForms Live to connect to the Agent.  Try naviagting to  http://localhost:42135 in your browser.  It should load the 'offline' version of WaveForms Live hosted by the Digilent Agent (it should look exactly like WaveFormsLive.com).

Let us know if that works and we'll go from there.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

Hey tsenneville,

Sorry, not in WaveForms live, just in the browser itself.  Like this:

localhost.PNG

 

If it is succesful you should see WaveForms Live, but with the localhost url:

agent-running.PNG

 

If it fails you will get an error page like this:

no-agent.PNG

 

 

 

Share this post


Link to post
Share on other sites

Got it!

Running Waveforms Live in the browser window (Chrome) I get a "Invalid Response from Agent".  But at least the drivers seem to be working.

what would you suggest I try now?

Share this post


Link to post
Share on other sites

Here is what is happening so far:

When I plug the Openscope in to the computer:

1. It is recognized by Windows ( in Devices and Printers) as Digilent Openscope.

2. The computer loads the drivers for COM3

3. For the Openscope to be recognized by Terra Term, the jumper at JP3 must be in the PROG position.

4. With COM3 set for 1250000 in Terra Term, I get a menu structure that lets me know that the drivers are loaded and working...I can calibrate the Openscope.

5. With WaveFroms Live running in by browser (chrome) I select ADD device and try to add Agent and select the default...http://loccalhost:42135 I get a "Error connecting to the Digilent Agent".

6. Sometimes I get an "Invaid Response from Agent" error.

I have now tried this procedure on two (2) different PCs running Windows 8.1 with the same result.

Any suggestions would be greatly appreciated.

T.

Share this post


Link to post
Share on other sites

One last observation:

Between Terra Term and the digilent "Network Connection" I have managed to make contact with the OpenScope but I cannot update the firmware and the Openscope will not pass the calibration test.

 

HELP!

Share this post


Link to post
Share on other sites

Hey tsenneville,

The output in TerraTerm confirms that the drivers and the hardware are working.

Load WaveForms Live via http://localhost:42135 confirms that the Agent is running and the Agents HTTP server is running.

However WaveForms Live seems to be having trouble connecting to the Agent.  This is most likely due to something like a firewall or antivirus software blocking the communication.

Can you go to the main page (Device Manager Page) and then open the side menu and click settings. Open the advanced menu and click change console log and select "Local Storage". This saves debug logs to your local storage. Now, try to add the OpenScope MZ to WaveForms Live like you did before (so you see the error). Once you run into the error, go back to the settings page and under advanced click "Export Log". This should download a .txt file that contains some of the debug information we collected and should give us some info on what is actually happening. The local storage debugging will only run during the session you enabled it. If you refresh WFL and still want to store the debug info, you'll have to go back to the settings page and set it to local storage again.

-Kristoff

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now