morieris

OpenScoe: Noise on the oscilloscope channes (fix)

Recommended Posts

As already mentioned in your FAQ, there are some issues with noise/peaks on the oscilloscope channels of the OpenScope. In the example (OpenScope_Peaks.png) you can see distortions of up to 200mVpp. The test setup:

  • Ch1: connected to DC1 @ 157mV
  • Ch2: shorted to GND
  • OpenScope is powered by a 5V USB power bank

I noticed, that the distortions can be completely eliminated by touching the PCB antenna of the MRF24. It seems to work equally well if you

  • tape down one of the insulated ground wires onto the PCB antenna.
  • or keep protective earth close to the outer edge of the PCB antenna (e.g. between two layers of insulating tape).

OpenScope_Peaks.png

Edited by morieris
to avoid misunderstandings in the initial post.

Share this post


Link to post
Share on other sites

Hey Morieris,

I spoke to Keith (our hardware / fimrware guy) and he said the noise you see on the signal is from the Wifi radio transmission.  Grounding the antenna is preventing the Wifi radio from transmitting which removes the noise, but this is not recommended.  You should only see this noise when the OpenScope MZ is connected to a Wifi network.  If you are connected via USB and want to remove the noise you can disconnect the OpenScope MZ from the Wifi network and the noise should go away.  We plan to reduce this noise in a future hardware rev.

Let us know if you have any questions about this.

Thanks!

-Kristoff

Share this post


Link to post
Share on other sites

More details from Garrett our board layout guy:

The crosstalk/noise that is coming from the Wifi is designed to transmit in three dimensions.  This makes it incredibly hard to shield such noise, when the transmitter is part of the design.  When you place ground or a thumb on the antenna, you are effectively driving all that energy into either the ground of the board or into your body.  Thus, the transmissions stop and can no longer couple to the board signals.
 
The Wifi also draws considerable power and causes power/ground noise in the process.  In our latest revision, we have added more decoupling to solve any ground/power issues, which seems to have made a significant difference.  I believe this was the bulk of the problem that the customer is seeing.
 
The power source (USB, Battery, etc… ) can have a significant impact based on the impedance the board sees. Which can exacerbate the power/ground issue mentioned above.  For instance, a long length, high impedance USB cable would cause power drops when the Wifi transmitted.  

Share this post


Link to post
Share on other sites

Just to be clear I did not "short" anything to ground or PE. I uploaded two pictures of the bush-fix. The green wire is connected to PE and is simpliy taped down between two layers of insulating tape, right above the antenna. It works best if the PE wire is close to the outer edge.

WIFI is still working well (my Access Point is 10m away + 3 walls). Powering via USB is not an option as I need a to measure independent of a common ground.

It might not be perfect, but at least there are no more peaks above the noise level.

IMG_20170626_211222.jpg

IMG_20170626_211324.jpg

Share this post


Link to post
Share on other sites

Dear all:

I tried another method, put plastic plate on WiFi antenna for insulation then stick copper tape over antenna area & part of WiFi module.

Effectiveness of WiFi transmission may reduce , but seems good if the distance from access point to openscope module is short.

Now it works well, and I hope update of multiplier & calibration function for prove operation...

 

1.png

Edited by yawn

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now