• 0
Kawnine

Can't power up Zybo FPGA Board

Question

Hi, I just bought a Zybo FPGA Dev board from Digikey and tried to power it up using USB. But I cannot see any indication of whether the board is alive, i.e. LED (LD11) is not  ON. The J7 is set for powering up via USB. I am quite new to this and would really appreciate some help. Thanks!
Edited by Kawnine

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @Kawnine,

Sorry to hear you are having issues with the Zybo. Have you tried another USB A to Micro-B Cable? Have you verified the USB A to Micro-B Cable works? Have you tried powering externally with a 5v power supply (changing J7 to reflect different power source)? If so does PGOOD light up(ld11)? If changing the USB A to Micro-B Cable does not fix the issue then would you be able to run a few tests with a DMM to identify where the problem might be. If you are able please make sure all external devices are unplugged from the board (headphones, pmods, etc.). This can help rule out external hardware problems and current limiting issues (limiting usually only causes problems when powering from USB ). It is particularly important to make sure that no HDMI devices are connected (monitors, etc.) because they will backpower our boards and sometimes screw up power supply initialization. With the power switch use the DMM to measure the output signal (middle pin) for voltage when in the on and off positions. 

thank you,

Jon  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now