• 0
c0y3

ChipkitCAN library and Deviot

Question

Hi All,

I have tried to use chipkitcan library from Sublime Deviot. Deviot uses platformio as build platform.

I have been able to install the microchip legacy peripheral libraries in platformio and so able to compile, but I run into linker issues, symbols not found. The linker scripts for my architecture are properly found but it sounds to me that the static library for the peripheral is not found. I have verified that the linker script contains the OPTIONAL("libcmh_peripheral.a") and the same for the architecture specific linker and library. This works fine with IMPDE and with Arduino IDE (after intalling peripheral libraries). Is there anything in the compiler or IDEs that is hardcoded to find the static libraries? any environment variable or so?

 

Thanks

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @c0y3,

I would suggest to post this question on the chipKIT forum. We do not have enough information about this specific issue to be helpful. We did not create the compiler or the environment. Unfortunately, We do not have the experience to properly answer your question.

cheers,

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now