• 0
Sign in to follow this  
jfrenzel

Programming the Wi-FIRE rev C

Question

I have a Wi-FIRE rev C board that I would like to program from the Arduino IDE. According to the ChipKIT wiki, the ChipKIT core has replaced the need for MPIDE. I hooked up the Wi-FIRE to the UART mini-USB on the top of the board (Call out 26 in the ref manual) and then tried to program from the Arduino IDE by selecting "Sketch > Upload" but I get an the following error

Programmer for Microchip PIC32 microcontrollers, Version 2.1.24
No target found.
    Copyright: (C) 2011-2015 Serge Vakulenko
An error occurred while uploading the sketch

My guess is that I need to use my chipKIT PGM programmer, but the Wi-FIRE ref manual does not discuss how to connect this. For example, JP3 and JP4 are not mentioned in the manual at all. (They are two, six pin staggered holes, one of which is labeled "JTAG"). It doesn't help that the PGM doesn't have much room to make a connection with all of the other stuff on the top of the board.

Am I missing something obvious?

 

UPDATE: I needed to change the selected COM port under "Tools" in the Arduino IDE. (Stumbled across Figure 9 here https://learn.digilentinc.com/Module/103?position=0

Edited by jfrenzel
Problem solved!

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The chipKIT PGM (or PICkit 3 or ICD 3 or Real ICE) are used only if you are trying to program through the MPLAB X IDE, rather than the Arduino IDE.

Given the output, it looks like pic32prog wasn't told what serial port to look at. Did you select a port after choosing the board?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this