• 0

problem atlys server web demo


Go to solution Solved by Mihaita,

Question

good morning

 

 

the example Atlys_AXI_Web_Server_Demo_v_1_02.zip doesn't work on ise design suite 14.7.

for the compilation and the programmation of the boards it's ok

 

i have the message autonegociate 100Mb/s on the console but no dialog with the computer on the network

the Library is lwip

 

 

best regards

Edited by KaitlynFranz
Added Tags
Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
  • Solution

The design is made with Xilinx Platform Studio 14.4 (http://www.xilinx.com/tools/platform.htm), you can open it with that version an follow the instructions in the PDF document under doc folder. It does not work with ISE.

The bsp, platform and library are part of the SDK needed to implement the lwip and the whole server application.

Link to post
Share on other sites
  • 0



good morning

 

the original programming file Atlys_Webserver_Demo.elf work very well (his size is 1531k)

 

after the compilation the  programming file Atlys_Webserver_Demo.elf doesn't work (his size is 1178k)

 

what are the compilation  options  to solve this problem ?

 

best regards

 

 

Link to post
Share on other sites
  • 0

good morning

 

it work well under  XPS 14.4 (server and client  (TCP HTTP TFTP) to 100Mbits/s)  but no Under XPS 14.7.

with XPS 14.7 there is one migration of project with one update of IPCORE (microblaze, INTC , LBRAM).

the size of file ELF is not good Under SDK 14.7 .

 

why ?

 

Thanks for your answer

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now