• 0
Sign in to follow this  
dnovick

Error in Analog/Digital Discovery Protocol tutorial

Question

So, I just received my Digital Discovery earlier this week. I've actually got a project coming up where I'll be able to make use of it, so thought I'd familiarize myself with the differences between it and the Analog Discovery. I proceeded to walk through the protocol tutorial that uses the ALS PMOD to demonstrate SPI interaction. I had never tried this with the AD2, and figured it would be a good test.

Unfortunately, after checking my work multiple times, I was still only getting back 0 signals. Thinking the problem could be the DD, I tried the same thing on the AD2 with the same results.

After scratching my head a few times, it occurred to me that the prescribed pin assignments looked strange. The tutorial says CS is assigned clock, and SCK is assigned to select. I went and double checked my hunch in the ALS docs, and indeed there was the problem. The tutorial incorrectly swaps these two pins. CS is (chip) select, and SCK is (serial) clock. 

Once I swapped the pins, all was well.

Just and FYI for the content team and others who might face the same issue.

Dave

https://reference.digilentinc.com/learn/instrumentation/tutorials/ad2-protocol-analyzer/start

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi Dave,

We're getting that mistake fixed right away. Thanks for letting us know and I apologize for the confusion that it caused!

 

Kaitlyn 

Edited by Commanderfranz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this