spfoster

Arty COM Port issue

Recommended Posts

Hi,

I am using vivado 2015.4 v2 and I can't get the Arty to show up as a COM port.

In Windows 7, I see the digilent device under USB Controllers but I do not see it connect as a COM port. I am also showing 2 devices with driver issues with non-useful names like usb controller and unknown device.

I can load the bitstream through the USB cable with no errors. I am running the hello world program and I can't connect to the board through teraterm etc as suggested in the tutorial.

Does this sound like a driver issue or does it sound like an issue with my block design or sdk setup?

I have tried uninstalling and reinstalling the drivers as shown here: https://www.xilinx.com/support/answers/54381.html

 

Thanks,

Scott 

 

Edited by spfoster
update for what I have tried

Share this post


Link to post
Share on other sites

Unfortunately, I don't "quite" have it going yet. I am using 2015.4 as mentioned but when I try to run the hello world project I get an error that says it can't halt the microblaze which I guess is a known issue with 2015.4. As a result, this program fails to load into the microblaze. Is this solved by the git repo by chance? 

Share this post


Link to post
Share on other sites

Hi @spfoster,

Could you take a screen shot of your block design. Are you following the getting started with Microblaze tutorial here? We now have 2 different Arty boards. Just to make sure this is the board you are using. Have you tried closing sdk and relaunching it from vivado again. I have got this issue before but i believe it is not related to your design.

cheers,

Jon

Share this post


Link to post
Share on other sites

Hi Jon,

 

That is the tutorial and board I am using. I have tried stopping the sdk and relaunching. I have also regenerated the bitstream and rexported it. No luck.

After I run as: hardware as shown in the tutorial I get an error that says: Error while launching program: Cannot stop MicroBlaze. Stalled  on instruction fetch.

The xilinx site says the MMI flow is recommended but I am new to this so I have not spent the time to figure out what that means.

Share this post


Link to post
Share on other sites

Hi @spfoster,

Have you tried this arty github project made for Vivado 2015.4?  I just went through the tutorial without an issue in Vivado 2016.4. I have in the past also done the tutorial in Vivado 205.4 as well.

cheers,

Jon

arty_hello_world.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now