• 0
yohboy

Manage interrupt on zybo with linux

Question

Hi !

I'm still working to add a RF module (MRF24J40) on my zybo. The SPI communication works fine, but I have some trouble with interrupt. I'm using linux-yocto as kernel.

Here is the design in vivado :

mini_991969design.png

The AXI_GPIO 0 and 1 are to use leds, buttons and swtichs on zybo. The AXI_SPI is used to communicate with MRF24J40. And the AXi_GPIO 2 is 3bits wide, one for wake, one for reset, and one for interrupt (for MRF24J40). The interrupts are enable on the AXI_GPIO2. I don't know if it is a good practice to enable interrupt for wake and reset too ?

Here is the interrupt enable in the zynq :

mini_203650interupt.png

Then the interesting part of my dts :

mini_740131dts.png

First of all, I'm not sure to understand what is the interrupt signal in the AXI_SPI. But it seems to have an interrupt, address 61 in kernel, and the interrupt from AXI_GPIO2 should be address 62 right ?

Here what I have if I execute a "cat /proc/interrupts" :

mini_752651catproc.png

It seems there isn't the axi_gpio2 interrupt. What am I doing wrong ? Do you have any tips ?

Regards,

Yohan

 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now