• 0
Sharat K

Unable to read IP file (when adding vivado-library-master repository)

Question

Dear Digilent,

First of all, I am running Windows 10 Pro 64Bit, Vivado 2015.4 Webpack and my hardware is the Zybo Board Rev.B.3

I am trying to instantiate the PMOD WiFi Module on one of my PMOD ports (There are 6 on this board so I chose the standard PMOD JE) but I face an error when trying to add the 'vivado-library-master' folder which I downloaded from GitHub.  I followed this link in order to do that and downloaded the library zip from this link (via GitHub)     

Once I had the ~123Mb Zip File downloaded:

1) I extracted the zip to a folder near my projects

2) Opened up Vivado, created a new project, selected my board (already copied my board files earlier)

3) Opened up project settings > IP tab > Repository Settings >>> and tried to select the downloaded folder (folder NAME: vivado-library-master), screenshot included

When I do this, click apply and close the project settings window, I am served a new window titled "critical messages" and it's screenshot is included in this post aswell

Basically It tells me that two of the IP's in this folder namely PmodSD_v1_0 and PmodWIFI_v1_0 could not be included because Vivado is "unable to read IP file"

**What I have already tried**

1) I have made sure that there are no spaces or special characters in the path to the folder containing the library

2) Downloaded this library zip file from GitHub multiple times to ensure that my downloaded isn't corrupt

3) Restarted my computer, created a fresh project and tried this again, this time choosing by board as the Arty FPGA Dev Board as done in a youtube video called "Pmod Monthly - November 2016 - Adding WiFi to your Digilent FPGA or Zynq Board"

 

The problem still persists and I am stuck! Please help!

ADD IP.jpg

ADD IP_1.jpg

ADD IP_2_error.jpg

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi Sharat,

The issue you are having has to do with the component.xml file in their IP cores. I have fixed the issue on our github. If you re-download the Vivado-libraries both the PmodWIFI and the PmodSD IP's will be available to use in Vivado 2015.4 as well as newer versions. Hope this helps!

cheers,

Jon

 

Edited by jpeyron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now