Question

                                  Just following Cmod A7 - Getting Started with Microblaze.

 I am getting an error that the path for project must have only one segment.  I don't have a clue as to what this means or how to fix it.

I have included my linker script.

Please help, if you can.

Thanks,

Eric.h

2017-01-24_20-21-12.png

lscript.ld

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

@eric.h,

My guess is that a "path segment" is a string separated by spaces.  I know Vivado has problem dealing with spaces in filenames or directory names.  Do you have spaces in any of your paths?  Either the install directory or your project directory?

Dan

Share this post


Link to post
Share on other sites
  • 0

@eric.h

The other possibility is that your directory path to your project is too long, if D@N's idea doesn't help, you may want to try putting your project as high in the filesystem as you can, perhaps right under your user directory.

Hope this helps,

Arthur

Share this post


Link to post
Share on other sites
  • 0

Hey artvvb -

Got it fixed.  I think I had the project opened twice.

Closed it all and tried again w/o problems.

Thanks for looking at this.

>>Eric.h

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now