• 0

zedboard stuck on "Launching: ps7_init"


Question

Hello,

I am trying to program a new zedboard and am having trouble programming the ps portion of the board with a bare metal application. I am following the tutorial outlined in the zynq book, in which you load some pre-written c code, which should blink some leds. Unfortunately, I keep getting stuck on the programming of the board. 

I select run as -> Launch On Hardware and it gets about 89% of the way though the program and then hangs on "Launching: ps7_init". Has anyone seen this before? I have tried it on both Ubuntu 16.04 and Windows 10, and both give the same problem. Furthermore, I am able to run "connect arm hw" in XMD console and it appears to work fine. I am also able to program just the PL fine as well through Vivado or SDK. I also don't think it is my header pin settings? I have them all set to gnd, which should be boot from JTAG. 

Other Info:

  • Operating System: Tried on both Windows 10 and Ubuntu 16.04 (Virtual Machine)
  • Vivado/SDK Version: Tried on both 2016.2 and 2016.4
  • ZedBoard: Latest Rev (D?)
  • Power Source: Provided wall plug into US 120v 60hz
Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now