• 0
jago

CoolRunner-II CPLD Starter Kit Rev.2.0

Question

Hi all,
 
I have a problem with my CoolRunner-II CPLD Starter Kit (Revision 2.0). I know this is an outdated product which is not supported by the latest version of Adept. But I had a look at the schematics of the current revision 3.0 and I noticed that the USB to JTAG controller is the same MCU like the one in revision 2.0. I'd like to know if it would be possible to reprogram the firmware of that controller and get my board to work with the latest Adept version.
 
Or is there another solution to use the board with a Xilinx iMPACT plugin? (I use ISE 14.7 on Windows 7 64 Bit) I already tried to use the latest plugin but I can not connect. As soon as I connect my Nexys 2 Board the plugin works fine.
 
I would be very happy if there was a way to work with my CoolRunner II without having to buy any additional JTAG cable or another Coolrunner-II Starter Kit which is almost the same like the one I already own.
 
Do you have any suggestions for me?
 
Best regards,
jago
Edited by KaitlynFranz

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

You are welcome.

Well, this is a weird revision that was never sold by Digilent.

 

As much as I know, it came accompanied with a CD. If this is true, then one way (the only one ?) to make it work is through the Adept software on that CD.

In this case you should uninstall all Adept software, install software from the CD.

Unfortunately what we know is that the current version of Adept is not supporting this revision.

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

Please take a look on the back of the board, near barcode, there should be something like "Rev. F". Do you own a rev. F ? This is the revision that Digilent is selling.

 

I think that using the board with iMPACT would be the best choice for you.

 

I was able to successfully work with iMPACT (version 14.7), see attached image

post-141-0-47524700-1424169047_thumb.png

I erased the CPLD and loaded the demo CPLD image shipped with the CoolRunner-II Starter (downloaded from http://www.digilentinc.com/Data/Products/CR2-STARTER/CR-II%20Demo.zip).

Are you able to do the same on your board ?

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

thanks for your response.

 

Unfortunately, I do not own a rev. F. My board is rev. D.

post-498-0-82662600-1424192119_thumb.jpg

 

This is not a new board. It's been some years since I bought it. At that time it came from Xilinx, but the utilities have always come from Digilent. So I hoped there was a way to get this old board back to work.

 

Windows recognizes the board as "Digilent USB Device".

 

When I start Adept the board enumerates as "Cr2s2" in the Connect drop down menu. The log shows the following lines:

===== Digilent Adept  =====
  Adept System  Rev 2.7
  Adept Runtime Rev 2.16
  Adept Application Rev 2.4.2
Copyright © 2010
Loading board information...
Warning:  Could not find specific board information
Default information loaded.
post-498-0-01337600-1424194065_thumb.png
 
 
I tried iMPACT v14.7 too. When I click on "Initialize Chain" the log shows (only copied the first 4 lines):
GUI --- Auto connect to cable...
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.

 

As a verification I tried my Nexys2 Board. It works with both Adept and iMPACT. In the iMPACT Cable Setup window, I noticed that the Port drop down shows my Nexys2 board, when Digilent USB JTAG Cable is selected. This drop down is empty when my CoolRunner-II board is connected.

post-498-0-33970500-1424194297_thumb.png

 

Share this post


Link to post
Share on other sites
  • 0
The software from the CD didn't work for me. I suppose it is because the drivers are incompatible with my 64 bit system. After the installation there are three programs in the start menu. ExPort, TransPort and CoolRunner-II Utility Window. ExPort and TransPort are complaining that dpcutil.dll is missing. CoolRunner-II Utility Window doesn't find jtsc.dll. When I connect the CPLD board no drivers are found.
 
I tried the software with VirtualBox on WinXP (32 bit) and Win7 (32 bit). All three programs can then be started. During the installation a message is showing up that unsigned drivers are being installed. This message is not shown on my 64 bit system.
 
But the problem is that I can not connect the USB device to the virtual system. So this seems to be no solution. Maybe I try the Windows XP Mode. If this doesn't work too I have to install a 32 bit system on a second hard drive. But this is really much effort. It would be really great if the Adept software or the iMPACT plugin could at least support the onboard JTAG programmer. The other functions of the board are not that important I think.

Share this post


Link to post
Share on other sites
  • 0

I am trying to find more information about this issue.

We knew that things should work when you have all versions of Adept uninstalled from the machine and install CRUW (found on the CD provided with the CR-II).

Share this post


Link to post
Share on other sites
  • 0

Thank you very much. Maybe I've got time to install a 32 bit system at the weekend. But I'm not sure. There are no WinXP drivers for my PC, but Win7 x86 could be worth a try.

Share this post


Link to post
Share on other sites
  • 0

I installed a fresh Win7 32 bit system and I was able to install the CRII Board files and drivers. It is possible to download the CPLD demo image using CoolRunner-II Utility Window. ExPort is still showing an error, but now it is because of a missing map file and the message box (post-498-0-02939100-1424624915_thumb.png) gives a hint that it could have something to do with the XILINX environment variable. I tried to set the variable to C:Xilinx (where I installed ISE), but it didn't work. Maybe the variable must be set to a subdirectory.

 

OK, CoolRunner-II Utility Window is working. It's nice to know that there is a way to use the board if I absolutely need to. But I still would prefer a way to use the board with my 64 bit system. It's a really stupid workaround to install a whole new system.

 

If it's totally impossible to add support for this revision to Adept, I will look for a cheap USB JTAG cable, because it will be more valuable to me than another CR-II board. Maybe a Digilent HS2 or one of these Xilinx clones selling on ebay for about 35 €...

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

In theory it should be possible to get Adept to recognize the board by reprogramming AVR part with the firmware used on the Rev F. However, we cannot guarantee that this will work as we haven't tried it here.

For this you would have to purchase a device capable of programming that particular AVR device. In this situation it would likely be more beneficial for you to put the money you'd spend on the AVR programmer toward a newer board.

So please tell us if you want to go in this direction (reprogramming the firmware) and we will discuss about obtaining the firmware image.

Share this post


Link to post
Share on other sites
  • 0

Thanks a lot.

 

You're right, Purchasing an AVR programmer only for this case is not the best solution. And I'm not planning to do something else with AVR at the moment. Nevertheless, it would be nice to get the Firmware. Maybe I buy a really cheap device (already seen some on ebay) or I could try to download the file using a FTDI FT2232. I already have a FT2232 here, but didn't build a board for it.

 

Do you know if the AVR device is readprotected? If not, I could make a backup of the original firmware. Just in case it would not work.

Share this post


Link to post
Share on other sites
  • 0

I'm on the same boat as jago (win7 64 bits, ISE 14.7), I was trying to pick up this old CPLD board that I got via XILINX, while trying to install the CoolRunner SW that came in the CD, the installer tries to install an old version of Adept, looking at the MSI logs fails with:

"...

MSI (s) (B4:E0) [07:20:00:949]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI5A5B.tmp, Entrypoint: ProcessDriverPackages
MSI (s) (B4!28) [07:20:00:949]: Creating MSIHANDLE (1138) of type 790531 for thread 11816
DIFXAPP: ENTER: ProcessDriverPackages()
MSI (s) (B4!28) [07:20:00:949]: Closing MSIHANDLE (1138) of type 790531 for thread 11816
MSI (s) (B4!28) [07:20:00:949]: Creating MSIHANDLE (1139) of type 790531 for thread 11816
DIFXAPP: ERROR - You need to use the 64-bit version of DIFXAPP.DLL to install drivers on this machine.
MSI (s) (B4!28) [07:20:00:949]: Closing MSIHANDLE (1139) of type 790531 for thread 11816
CustomAction MsiProcessDrivers returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

..."

 

Which confirms jago, where it requires a 32 bit system. cfatu, would be possible to generate a 64 bit installer?

 

Thanks!

 

Share this post


Link to post
Share on other sites
  • 0

Ok, found a interesting way to make this work on a single computer!

 

So the way I manage to get this working with a Single PC was using:

- Windows Virtual PC & XP Mode, this create a VM (running windows XP) and allows to share the USB Port with the VM, so on My VM, I installed the Cool Runner II App from the CPLD Starter KIT Resource CD, as well as the default settings (Stand Alone Programming tools) on ISE Design Suite 10.1 (didn't need any license key), and I'm able to program, erase, verify and read from the Cool Runner APP my board.

 

Hopefully this helps!

 

Edited by Luis
adding tool

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now