• 1

How to restore FT2232 EEPROM back to factory settings?


Hi Everyone,

Just accidentally flashed the EEPROM attached to the FT2232 device on the Arty. The board is dead without the USB connection. Been using for 2 months without issues until today.

In Vivado it is showing:

 "ERROR: [Labtoolstcl 44-469] There is no current hw_target.". 

when trying to Auto Connect with the target in Hardware Manager.

Within FT_Prog (FTDI's flash tool), the registers (e.g. serial number, vendor ID, D2XX/VCP driver ...) can all be read and modified. How can it be restored back to Digilent factory setting? Is there an FT_Prog template that we can use?



Link to post
Share on other sites

Recommended Posts

  • 0

Hello @JColvin, @Bianca

I accidentally modified the EEPROM of my device "Xilinx Kintex UltraScale FPGA KCU105 Evaluation Kit" via FT prog software. I have changeg values in "Produc Desc" and "Manufacturer Desc" fields and now, Vivado 2021 ISE don't recognize the FPGA to program it trough the hardware programmer. 

May I please have the recovery instructions?

Thank you very much.

Link to post
Share on other sites
  • 0

Hi @druiz,

I'll have to find out which Digilent programmer the KCU115 uses before I can help you; UG917 from Xilinx unhelpfully just calls it a "Digilent onboard USB-to-JTAG configuration logic module". I'll post back here once I learn what it is.


Link to post
Share on other sites
  • 0



I have been using Genesys2 FPGA Digilent Board on Vivado in Centos with the already present settings of Port A having Driver as D2XX Direct and Hardware as 245 FIFO. Recently I tried to change these configurations through FT_Prog to Driver = virtual COM Port and Hardware = RS232 UART (the reason to do so is because we are seeing these settings in our actual chip and the chip is showing a libusb open () error and we thought that changing the Genesys2 settings to the chip's settings could give us the same error, although it didn't, and unfortunately the interface card associated the chip is not being programmed through FT_Prog).


However, when trying to change the configurations of Genesys2 back to the original settings of D2XX Direct and 245 FIFO (and serial numbers also), now Vivado is not detecting the board. Is there a way to restore factory settings of this Genesys2 board, so that Vivado detects it? On lsusb, the device appears showing both JTAG and UART ports, but Vivado is not detecting, and also tried restarting the computer and such minor fixes, but still the same. (Including changing the location of drive files "sudo cp /soft/Xilinx/Vivado/2018.3/data/xicom/cable_drivers/lin64/install_script/install_drivers/*.rules /etc/udev/rules.d ")


Vivado shows,
INFO: [Labtools 27-2285] Connecting to hw_server url TCP:localhost:3121

disconnect_hw_server localhost:3121


INFO: [Labtools 27-2285] Connecting to hw_server url TCP:localhost:3121


How do I recover this? Thanks!


Sincerely yours,



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now