• 0

How to restore FT2232 EEPROM back to factory settings?


Question

Hi Everyone,

Just accidentally flashed the EEPROM attached to the FT2232 device on the Arty. The board is dead without the USB connection. Been using for 2 months without issues until today.

In Vivado it is showing:

 "ERROR: [Labtoolstcl 44-469] There is no current hw_target.". 

when trying to Auto Connect with the target in Hardware Manager.

Within FT_Prog (FTDI's flash tool), the registers (e.g. serial number, vendor ID, D2XX/VCP driver ...) can all be read and modified. How can it be restored back to Digilent factory setting? Is there an FT_Prog template that we can use?

Thanks,

Robin

Link to post
Share on other sites

Recommended Posts

  • 0

Hi,

I'm having the same exact problem as @mixsemi i accidentally erased EEPROM attached to the FT2232 device on the Arty.

i used the FT_PROG utility provided by the FTDI (http://www.ftdichip.com/Support/Utilities.htm#FT_PROG) to change the driver from "Virtual Com Port" to "D2XX Direct" to test an application that i am developing in my ARTY board.

After that my arty is no longer recognized by Vivado hw manager. It's state remains unconnected while arty is plugged and all power leds are ON.

Before using the FT_Prog utility arty was working perfect in Vivado.

In the Device Manager of windows i can see two USB serial converters A & B while i think before using the FT_Prog it was Digilent USB converter or something like that.

Is there something i can do to fix this?

BR,

skakon

PS1: i had followed the solutions provided here without success

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now