• 0

TCL script in tutorial out of date


Question

In order to figure out how to connect the on-board switches, buttons, and LEDs to Microblaze, I tried to follow the instructions in this Learnable. Sadly, the 'create_project.tcl' script seems out of date and can't be used to create a board design. I get the following error messages -

ERROR: This script was generated using Vivado <2015.4> and is being run in <2016.3> of Vivado. Please run the script in Vivado <2015.4> then open the design in Vivado <2016.3>. Upgrade the design by running "Tools => Report => Report IP Status...", then run write_bd_tcl to create an updated script.
ERROR: [BD 5-229] Please open or create a block design first.
ERROR: [Common 17-39] 'get_bd_designs' failed due to earlier errors.

    while executing
"get_bd_designs"
    invoked from within
"set design_name [get_bd_designs]"
    (file "./create_project.tcl" line 106)

 

Trying to run the entries in the create_project.tcl one at a time, or one at a time after creating and opening a block design, also failed with similar messages. Is there something obvious I'm missing? Could I get an updated version of the script?

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1

Hi wanderso,

You could download Vivado 2015.4 and use it to generate the project. From there you can follow the first error message you listed and open the project in Vivado 2016.3 and run Report IP Status. You won't need to run write_bd_tcl again in order to update the script unless you plan on distributing your project. You could also wait for an update to the .tcl script to get it working in Vivado 2016.3. I could do this but would need to know which project and for what board you are using.

cheers,

Jon  

Link to post
Share on other sites
  • 0

Hi Wanderso,

I have attach the BSD project that i have updated to work on Vivado 2016.3. I will update the other two projects in Github as well as attach them to this thread in the next day or two. Hope this helps! 

Edit: Looking at the other two projects they both worked on Vivado 2016.3. The GPIO project does not have IP's , the VHDL generates with no issue and with the XADC project you just need to upgrade the IP in the project. 

cheers,

on

BSD16.zip

Edited by jpeyron
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now