• 0
Sign in to follow this  

"Program Failed" for some demo projects..


Hello everyone!

I'm using an Atlys board and I've succeeded in programming some of the demo projects (like the GPIO and UART demo project DSD-0000327).

But when I tried to program the VmodCAM project DSD-0000309 or DSD-0000310 using Xilinx iMPACT, it said "Program Failed" when the progress bar went to about 4%, and then the board rebooted.

The following was displayed in the iMPACT console:

PROGRESS_START - Starting Operation.
Maximum TCK operating frequency for this device chain: 0.
Validating chain...
Boundary-scan chain validated successfully.
'1': Programming device...
 LCK_cycle = NoWait.
LCK cycle: NoWait
'1': Reading status register contents...
INFO:iMPACT:2219 - Status register values:
INFO:iMPACT - 0000 0000 0000 0000 
PROGRESS_END - End Operation.
Elapsed time =      5 sec.

I've tried the bit files provided by Digilent and those generated by myself (in ISE 14.7) from the source files. Neither of them worked. (The demo project was built in ISE 13.2, tested in ISE 13.1, according to Digilent's comment. But I think it should work in ISE 14.7 as well. I updated the IP cores used in the project anyway)

Then I programmed the flash with the bit file using Xilinx Adept, but the board fell into endless reboot loop...

I don't know why this demo project can not be downloaded... Any help would be appreciated :-)

Share this post

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hello cfatu,


Thank you for pointing this out!

Finally I found that I wasn't using the correct power supply. I noticed that when some "big" project (which may consume more power) was downloaded to the FPGA, the input voltage fell below 5.0V and then the board could not work. Then I realized that the board had not enough power.

The reference manual states that "The Atlys board requires an external 5V, 4A or greater power source with a coax center-positive 2.1mm internal-diameter plug (a suitable supply is provided as a part of the Atlys kit)".

Everything is working now, after I found the right power supply.
Thank you very much!

Share this post

Link to post
Share on other sites
  • 0



I downloaded  the VmodCAM project DSD-0000309

I was able to successfully program the bit file to Atlys, using both the binary provided in the zip file and the binary I generated from the sources.

I used Xilinx tools version 14.7 (chose to migrate only the project).


From the fact that you are able to program other demos we can conclude that most probably the FPGA is not damaged and the board is good.

So, it is possible that your board has not enough power while programming the VmodCAM demo. And this might be due to the fact that your VmodCAM is attached. So, please disconnect any device from Atlys and try to program the VmodCAM demo. Is it working ? What amperage is displayed on your power source? 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this