• 0
AchilleTalon

Analog Discovery and Waveforms on Linux

Question

I am unable to make Waveforms working with my Analog Discovery on Linux.

I installed Adept 2 and Waveform, when I plug my device in the usb port I have it recognized. It seems it is Waveforms that refuse to recognize the device or something bad happen as soon as I start Waveforms to the USB connection. Here is the log output when I connect the device in the USB port:

oct 06 20:49:09 feynman kernel: usb 2-1.7.4: USB disconnect, device number 11
oct 06 20:49:09 feynman dbus[1324]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
oct 06 20:49:09 feynman dbus[1324]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory.
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: new high-speed USB device number 12 using ehci-pci
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: New USB device found, idVendor=0403, idProduct=6014
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: Product: Digilent USB Device
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: Manufacturer: Digilent
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: SerialNumber: 210244540938
oct 06 20:49:13 feynman kernel: ftdi_sio 2-1.7.4:1.0: FTDI USB Serial Device converter detected
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: Detected FT232H
oct 06 20:49:13 feynman kernel: usb 2-1.7.4: FTDI USB Serial Device converter now attached to ttyUSB0
oct 06 20:49:13 feynman mtp-probe[14777]: checking bus 2, device 12: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.7/2-1.7.4"
oct 06 20:49:13 feynman mtp-probe[14777]: bus: 2, device: 12 was not an MTP device
oct 06 20:49:13 feynman dbus[1324]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedesktop.Avahi.service'
oct 06 20:49:13 feynman dbus[1324]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus-org.freedesktop.Avahi.service failed to load: No such file or directory.
oct 06 20:49:28 feynman kernel: ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
oct 06 20:49:28 feynman kernel: ftdi_sio 2-1.7.4:1.0: device disconnected
 

From 20:49:09 to 20:49:13, these messages are issued when I plug the device. At 20:49:28, these are the messages when I start Waveforms.

Anyone can tell me what is wrong? Why the device get disconnected when I start Waveforms? And why do I get the device reported in the Waveforms GUI anyway? As shown on the attached screenshot, the serial number of the device is reported correctly.

Any help to resolve this issue would be appreciated.

 

AnalogDiscovery.jpg

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi Daniel,

I am running a 3.18.25 kernel. I don't believe it is kernel related. I am still having this problem. For now, I have not much time to investigate it. However, I surely would like to have it resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now