Question

12 answers to this question

Recommended Posts

  • 1

I don't think it is related to supplying issue. At least I don't see any difference in communication errors when supplying the Raspberry and USB hub separately.

 

Forcing the USB to slower full-speed seems to be an improvement, by adding dwc_otg.speed=1 to /boot/cmdline.txt

http://www.raspberrypi.org/forums/viewtopic.php?f=44&t=8010&start=75

 

Most of the cases it does succeed to open the device, configure the AWG and perform an acquisition.

pi@raspberrypi ~ $ python AnalogOutIn.py 
Version: 2.8.9
Number of Devices: 1
Opening first device
Configure and start first analog out channel
1 = Sine wave

Configure analog in
Set range for all channels
Wait after first device opening the analog in offset to stabilize
Starting acquisition
   waiting to finish
   done
   reading data
DC: -0.0128179349414V

Share this post


Link to post
Share on other sites
  • 0

Hey! Great! 

 

I was thinking of getting a tiny PC for my workbench (e,g, Intel NUC) but I just saw this..

 

I've just installed those two packages on my original CubieBoard running Linaro and it works really well. If you are not familiar with the CubieBoard there is a newer dual core version for $59 from https://www.miniand.com/products/Cubieboard%20A20%20Dev%20Board (and others). It will be pretty much the same as the SparkFun PCduino3 (https://www.sparkfun.com/products/12856) but with two USB ports (one for the keyboard, and one for the Electronics Explorer).

 

So rather than a laptop, my setup is a 24" monitor, the CubieBoard (running from a USB charger), a small wireless keyboard with a built in track pad, and my Electronics Explorer!

 

I just want to get a desk clamp stand for the monitor...

Share this post


Link to post
Share on other sites
  • 0

I tried installing it on the Raspberry pi.

 

At first it complained because libc6 was version 2.13 and it needed 2.14 or more.  I upgraded to jessie from wheezy which has libc6 2.19. 

The installation went fine but when I try to run it I get an illegal instruction error :/

Share this post


Link to post
Share on other sites
  • 0

Currently we have some problem with the USB communication or Raspberry PI with Analog Discovery.

We will get you back after this problem is solved.

Share this post


Link to post
Share on other sites
  • 0

Funny I'm reading this now. I'm actually using a Raspberry Pi 2 with the Analog Discovery Module right now, trying to get *some* version of the Waveforms SDK to run.

 

I had a great data acquisition program running in my Ubuntu machine and was disappointed to see that it didn't port over to the ARM architecture. I had a similar experience with the libc6 problem.

 

Now I keep getting a "failed to open device" error, but not always.

 

What I've done so far is installed the Waveforms 3 .deb file into my Raspberry Pi, extracted all the /usr/lib/libdwf.so* files, and uninstalled the .deb again. Next I installed the Adept Runtime and the i386 Waveforms SDK tar file into the Pi, but before running ldconfig I restored the Waveforms 3 libdwf files that I had backed up.

 

Now it mostly doesn't work but if I run the example code AnalogIn_Sample.py, it sometimes works (kind of). Usually it says "failed to open device" but occasionally it reads a value.

 

This is a modified version of AnalogIn_Sample which actually scans 500 samples and prints the voltages on screen. Consecutive samples often get frozen at the same value, which makes me wonder if something is interrupting the serial commands.

 

Anyway, it's strange that the data acquisition sometimes works. I'm going to keep hacking away at it. Any advice?

Share this post


Link to post
Share on other sites
  • 0

The Analog Discovery is not (yet) working with Raspberry Pi 1&2. There seems to be a problem between FTDI driver libraries and Raspberry, USB packets are randomly lost or altered.

 

The Electronics Explorer, having Cypress USB controller using Digilent firmware and driver, works fine on Raspberry and other ARM platforms.

 

The Discovery is working on Zybo Linux and ZED Linaro, and we got reports that it is working on other ARM platforms too.

Share this post


Link to post
Share on other sites
  • 0

For what it's worth, I seem to get fewer errors if I use a USB hub powered with an external supply.

 

Note: by fewer errors I mean that I'm at least able to connect to the device.

dwf.FDwfDeviceOpen(c_int(-1), byref(hdwf))

if hdwf.value == hdwfNone.value:
    print "failed to open device"    ## Doesn't happen nearly as often with external power supply
    quit()

I'll keep an eye out for FTDI updates. Unfortunately I don't have an electronics explorer handy  :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now