• 0
dsperlich

ATLYS programming FX2 lost configuration

Question

Hi,

my ATLYS baord is not detected by an operating system any more as valid USB device when connected to the PROG mirco usb port. On linux i see for example:

[85564.500749] usb 2-1.2: new high-speed USB device number 80 using ehci-pci
[85579.582195] usb 2-1.2: device descriptor read/64, error -110
[85594.764710] usb 2-1.2: device descriptor read/64, error -110

 

I played now a little bit with it, and are pritty convinced that the content of the EEPROM for the FX2 is damaged. Sadly i cannot find a copy of the eeprom content for atlys on the internet. I actuallys found one from an nexys 2 board and when i flash this with the FX2 software on the eeprom, the atlys is recogniced again even with adept, but this old version does not seem to support all features needed by a reacent adept. I mean i can configure my bitfiles, but when i try to flash them, adept tells me that the communication with the FPGA failed.

 

So is there somewhere the firmware of an ATLYS FX2 availiable, so i can recover my ATLYS properly?

 

Cheers

Dennis

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi,

 

thanks for the tool. For future reference i found now, that the problem was not the NEXYS 2 version of the FX2 firmware (file called donbusb.iic if you want to search the internet :-), as it looks like digilent does now want to distribute the firmware publically any more even though they did it in the past with Digilent_USB_Firmware_Upgrader.exe), but the digilent tool is nicer to use than the cypress tools. The problem was missing solder connections when i soldered a new FX2 on my atlys, as i first suspected a broken USB frontend as probing with a scope showed that the eeprom was still read properly.

 

Cheers

Dennis

Share this post


Link to post
Share on other sites
  • 0

I actually have the same problem, sorry, it happened after i was messing with trying to run some HDMI2USB stuff on the atlys, it now no longer is recognized in Device manager or in Digilent Adept, can i have the eeprom contents via PM too ? The donbusb.iic is no longer even on the internet so i cant try with that one..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now