• 0
Sign in to follow this  
Joe Nolan

XC32 v 1.42 file path issue

Question

I am using the chipKIT Pro MX7; MPLABX IDE v 3.10; and the XC32 v 1.42 compiler. I am working through the Learn.Digilentinc.com  project 0 and I am getting a "system can't find the path specified" error when building the provided code. This error is shown below:

make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
make[1]: Entering directory 'C:/LAB2B/project_0_1.X'
make  -f nbproject/Makefile-default.mk dist/default/production/project_0_1.X.production.hex
make[2]: Entering directory 'C:/LAB2B/project_0_1.X'
The system cannot find the path specified.
make[2]: *** [build/default/production/project_0_1_source.o] Error 1
make[2]: *** Waiting for unfinished jobs....
The system cannot find the path specified.
make[2]: *** [build/default/production/Mx7.o] Error 1
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2

There is also a blue clickable error link shown below:

"C:\Program Files (x86)\Microchip\xc32\v1.42\bin\xc32-gcc.exe" -g -x c -c -mprocessor=32MX795F512L -MMD -MF build/default/production/project_0_1_source.o.d -o build/default/production/project_0_1_source.o project_0_1_source.c 
nbproject/Makefile-default.mk:111: recipe for target 'build/default/production/project_0_1_source.o' failed
"C:\Program Files (x86)\Microchip\xc32\v1.42\bin\xc32-gcc.exe" -g -x c -c -mprocessor=32MX795F512L -MMD -MF build/default/production/Mx7.o.d -o build/default/production/Mx7.o Mx7.c 

When I Click on the blue error link it takes me to a maker-file and the second line shown below is highlighted:


${OBJECTDIR}/project_0_1_source.o: project_0_1_source.c  nbproject/Makefile-${CND_CONF}.mk
    @${MKDIR} "${OBJECTDIR}" 
    @${RM} ${OBJECTDIR}/project_0_1_source.o.d 
    @${RM} ${OBJECTDIR}/project_0_1_source.o 
    @${FIXDEPS} "${OBJECTDIR}/project_0_1_source.o.d" $(SILENT) -rsi ${MP_CC_DIR}../  -c ${MP_CC}  $(MP_EXTRA_CC_PRE)  -g -x c -c -mprocessor=$(MP_PROCESSOR_OPTION)  -MMD -MF "${OBJECTDIR}/project_0_1_source.o.d" -o ${OBJECTDIR}/project_0_1_source.o project_0_1_source.c   
    

I also get a "configuration loading error" shown below:

info: Configuration "default" will build with toolchain "XC32" at "C:\Program Files (x86)\Microchip\xc32\v1.42\bin".

So, it seems I need to specify a path. Is it done in the configuration bits? Any help with this would be greatly appreciated.


 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

UPDATE: Problem Solved

Just in case anybody else is struggling with compiler file path issues, I will post what solved this issue for me. After you install the XC32 v 1.42 compiler, you also need to install the pic32 legacy peripheral libraries. After I installed the legacy peripheral libraries it eliminated the "system can't find path" errors, but didn't effect the "build/default/production" errors. After several hours, this is what worked:

  • Uninstall the XC32 compiler
  • Re-install the XC32 compiler
  • Re-install pic32 legacy peripheral libraries  

You do have to make sure that the peripheral libraries are in the same build tools path that you see from the tools>options>embedded>build tools screen. The compiler still generates alot of useless warnings( it seems that microchip prefers that people use their HARMONY software ) but the project builds successfully, time after time.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this