• 0

I2C data acquistion from Analog Discovery


Question

Hello, 

I am a new user of analog discovery. I have an Arduino talking to my sensor through a 5v to 3.3 V level converter using I2C protocol. The code works fine and gets me the desired output on the serial port but when I try to connect the SDA and SCL lines to the analog discovery on the pin 7 (Data) and Pin 15 (clock) lines, I dont see any signals getting recorded. I am interested in seeing the clock and data lines with the addresses and data that is being written on the lines. But it either gives me Error status or no result after getting triggered. The snapshot is attached below: 

I wanted to know if I am following all the necessary steps in initializing the analog discovery. 
1. Connect the wires to the 2 digital lines of analog discovery ( Pin 7,15 here)
2. Assign the right DIO pins as data and clock lines in the waveforms software. 
3. Click the Red T button to set the trigger option. --> Start signal as trigger is the condition I used in the image below. 
 but I also tried different trigger settings like,  SDA = Ignore and SCL = Rising edge.  Both of them gives me the error blocks  as below. 
3. Click Run button
4. Reset the Arduino. 
5. Stop. 

I am interested in seeing the start, addresses in hex, ACK/ NACK signals labeled. Can anybody tell me if there is some required program to be run before I able to see them? 

Thanks & Regards, 

Analog Discovery.JPG

Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now