• 0
Sign in to follow this  
timmolter

"Failed to open device" when running python examples

Question

I just purchased an Analog Discovery and have been enjoying it so far. The OSX Waveforms2105 app works flawlessly. 

 

I'm now trying to run the python example code in the SDK in order to write my own software. If I run `DigitalOut_Pins.py`, I get the following:

 

DWF Version: 3.3.5
Opening first device
failed to open device

Any ideas? Can I debug this in any way? Thanks.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I solved it, but I'm not sure exactly why it now works. Before I was referencing the dwf framework with 

/Applications/WaveForms.app/Contents/Frameworks/dwf.framework/Versions/A/dwf

because that's where the framework ended up when I installed Waveforms. I updated the python code appropriately.

Then I tried moving the framework to the directory referenced in the original code:

/Library/Frameworks/dwf.framework/dwf

And then it worked. Not sure what the difference is though.

Share this post


Link to post
Share on other sites
  • 0

Hello,

On OS X the proper location of the shared frameworks, as the installer disk image arrow suggests is the /Library/Frameworks.
The application bundle can also incorporate the framework and link to it as: -rpath @executable_path/../Frameworks -framework dwf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this